Icon problem is not fixed

I’ve been finding a bunch of posts about the icon problem that have been saying that the problem has been resolved, but it definitely has not been. I’m getting the proper icon on my .exe file and my desktop link, but the taskbar icon and title-bar icons are still showing the Unreal logo. (Actually, this last build gave me just that small line you see on the title bar.)

My icon started as a .png that was converted into a proper icon file at 256x256.

I’m having the same problem no matter what build I do–shipping or development and 32 or 64 bit.

Since I’ve been seeing this listed as a “resolved” issue, I’m submitting this as a bug report.

Thanks,

-Marc

Hi Mbublitz,

Previous post was deleted. I have not been able to reproduce this error on my end.

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

  • Have you tried this with a .ico file?

  • What size image are you currently using?

  • Where are you setting the .ico file?

The icon file was added in the project settings under Platforms and in the Windows section for the Game Icon.

I just created a brand new “Puzzle” game project, set my icon file, and packaged for Windows 32-bit (Development Package) and still getting the same thing. The icon on the actual .exe file is correct, but the icons when opening the game to play it are wrong.

85239-stillbadicons.png

What filetype are you using for the icon? make sure that it is a 256x256 .ico file.

It is. And, as I said, it sets the actual .EXE icon properly, but the taskbar and in-game icons are not being set properly and are defaulting to the Unreal Logo icon. I attempted to attach a copy of my .ico file, but it won’t accept .ico file attachments here, I see. Also, I just wanted to add that I also created a blank project and made a shipping package, and get the same results.

If you could, place the .ico in the .zip and then upload the .zip here. The reason I requested the clarification is that on my end a packaged project receives the icon on both the .exe and within the toolbar. I’m curious to see if there is some significant difference between the two that may be causing the error to occur.

Here’s my zipped icon file.

link text

It looks as though it may be limited to your icon file. I’m attaching a sample .ico file that seems to work. Can you test this on your end to see if it appears correctly? link text

When I use your icon file for the blank project I created earlier, I’m getting your icon on the .exe file (as I got mine) but instead of getting your icon in the other places, or the unreal icon, I’m getting a generic icon.

85411-stillbad2.png

What OS are you currently on?

Windows 8.1

Hi MBublitz,

I wanted to update to let you know that I am still looking into this. I am getting wildly varied results so once I know more information I’ll post back here with an update.

I am getting identical results as Mbublitz. I am packaging a 64-bit binary and running it on Windows 10. I am seeing this in my game project as well as a simple blank project. Seeing this in development and shipping packages.

When I use Mbublitz’s, I get that single line icon as seen in his first image. When I use Adam’s icon i get the same results as in his second image.

The only time I have ever seen it working is with the default icon included in UE4. If I modify 1 pixel from the default icon, it doesn’t work any more and I get the results in the second image.

Here is a shot from Axialis IconWorkshop Adam icon, Mbublitz icon, UE4 Default icon, Modified UE4 default icon.

Can you provide the source asset for your icon? I’ve been attempting to reproduce this on my end, however I still cannot reproduce the errors you are seeing with the asset I linked. Preferably, if you could provide the PSD for the source asset on your icon it would help us to narrow down what may be occurring.

Hi MBublitz,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

Sorry, had somehow missed your request. Here’s the source psd file.

link text

Hi MBublitz,

I apologize for the delayed response. I have been attempting to reproduce this on my end for quite some time, however, after getting your .psd file I was able to get a working .ico file for the packaged windows project.

I’m attaching the .ico I created, please try this and see if it works on your end. I altered the name to allow the website converter to recognize the .png and change it to a .ico. The steps I used can be found below:

[ico file][2]

  1. Open Editor (any project)
  2. Open File>Project Settings>Windows
  3. Set Game Icon to .ico file
  4. File>Package Project>Windows>Win(64 - bit
  5. Open .exe at packaged location

Unfortunately, I downloaded your new icon file and tried using it in my Labyrinth Larry project, and got the same results:

As you can see, it’s good for the executable, but not for the in-game icon still.

So, I tried a brand new, completely blank Blueprints Project and set the icon file that you sent back with the same results:

88913-stillnoicon2.png

I’m on an un-modified 4.11.2 build of the engine. I don’t know why you’re able to get it there, and we’re not getting it here.

I’m experiencing the same problem. Funny thing is, if you Right Click → Properties on your .exe, you’ll see the icon. It’s pretty strange

Edit: Strangely, it is now fixed…

http://puu.sh/oAv3L/def0eba549.png

Hi Kensei,

Are you saying that when you use right click>properties the icon now appears on the taskbar and the .exe window? If so, can you try this and see if it fixes your error, Mbublitz?