Icon problem is not fixed

No, this has no effect. It would appear that he has a slightly different icon problem than mine. It looks like his executable file shows the Unreal Icon, but the properties page shows the correct icon. My executable and properties both show the correct icon, but the in-game icon on the window and the task bar are incorrect.

I think I may have found something about what is going on. (Or just confused the matter more.)

I took my original 256x256 png file and loaded it into IcoFX Portable (I purposely didn’t put a link to the download site because even though I had no problems with the site, and it seems legit, I didn’t want to be responsible for anyone else’s computer, so google search it and go there at your own risk. It’s free.)

Anyway, I loaded my image into this program and under the Icon menu did a Create Windows Icon.

At first this new icon didn’t work, but if I reset the icon to the default UE4 icon, then changed it back to this icon, it seemed to update it and now shows on the title bar:

(The column of icons down the left side are all the layers that are in that file now. Size & bit depth.)

I still don’t have an icon on the actual window itself, but I’d much rather have NO icon than a generic icon. I’m including the icon file that seems to be working(ish) right now for you to examine and see if there are any clues you can gather from it.

I’m still running tests to see if I can figure out what the magical sizes and bit-depths are that are making it work over here, but this is a start. At least I’m seeing an icon on the task bar now.

[link text][2]

Hi Mbublitz,

I apologize for the delayed responses. I’ve been trying to reproduce this on my end, but have not been able to. A co-worker of mine was able to reproduce part of the issue and I noticed one key difference: Operating System. Do you have a Windows 7 machine that you could try this on? I double checked the most recent icon and it still shows up as I expect on both the taskbar and .exe with no modifications on my end.

I am having the same issue. 4.10 from source.

I found the exe in the top level build destination folder has the correct icon, but in \Binaries\Win64 the exe icon is incorrect.

I think part of the issue might be that it is a project from source rather than editor only? Do you have to set the icon from source before building the editor?

I wanted to add, that for now I am successfully using ‘Resource Hacker’ on the Win64 exe so my program will have the correct icon in case any others are short on time to figure this out.

Hi HartLabs,

Which OS are you currently using?

Apologies that it’s taken so long to respond. Been extremely busy. Unfortunately, at this time, I do not have a Windows 7 that I can test on, and I hesitate to upgrade this laptop to Windows 10. (Everything works the way I want it, and am used to it.) But I may have one other option, I will have to see. I just don’t know if the other specs of the machine will allow it to run the editor or not.

I am on Windows 8.1

I do not have a Window 7 machine to test on, as I see other comments mentioning it. I did try several things to clear icon cache as there were some other threads mentioning it as a possibility. Opening the exe with Resource Hacker does confirm the wrong icon is built in though, not just in cache.

Oh also, I did try the icon file you posted to confirm that it was not some file format issue and it did not work correctly.

thanks for this. I had the same problem…tried so many different things and only IcoFX worked. I also got the icon to show up in the window as well.

When I open my program exe (WindowsNoEditor\ITA\Binaries\Win64\ITA-Win64-Shipping.exe) using visual studio, there are two icon files attached. One has just my 256x256x32 bit png icon in it (correct). The other has a composite icon with not only mine, but also the default Unreal icons at 24x24, 32x32, 40x40, 48x48, 64x64, and 256x256. Depending on if I set the view in windows to be Extra Large, Large, Medium, or small icons I get either mine or unreal’s icon. This is despite the fact that the icon file I specified in my project settings has my icon at all those sizes. The build process is apparently copying the 256x256 version of mine icon into the unreal default icon file, but ignoring all the other sizes.

Do you have this in your .rc?

#include "Runtime/Launch/Resources/Windows/resource.h"

We also had the problem you describe until added this line. I actually don’t understand how rc.exe worked at all without this line, because that header defines what IDICON_UE4Game is.

This is not a FIX but an alternative solution that I’ve found to work quite well.

The first thing is to add:
#include “Runtime/Launch/Resources/Windows/resource.h”
after line 12 in YourProject/Source/YourProject/Resources/YourProject.rc file.

Now, package your Shipping build as you would inside UE4. Then download a windows installer program like Inno Setup, which is free. With Inno Setup you can include in the setup file (.iss file) a desktop icon. You then build and compile within Inno Setup. After it finishes, go to the output folder you designated in the setup file and run the exe installer yourself. You should now notice you have all 3 icons (your icons) the Project icon, the Toolbar Icon and the Desktop Icon.

For the record, adding that include to our .rc fixed our issue.

I have the same issue, when I choose to view medium icons it show the default Unreal icon but another size shows my game icon.

“When I open my program exe (WindowsNoEditor\ITA\Binaries\Win64\ITA-Win64-Shipping.exe) using visual studio, there are two icon files attached. One has just my 256x256x32 bit png icon in it (correct). The other has a composite icon with not only mine, but also the default Unreal icons at 24x24, 32x32, 40x40, 48x48, 64x64, and 256x256. Depending on if I set the view in windows to be Extra Large, Large, Medium, or small icons I get either mine or unreal’s icon. This is despite the fact that the icon file I specified in my project settings has my icon at all those sizes. The build process is apparently copying the 256x256 version of mine icon into the unreal default icon file, but ignoring all the other sizes.”

I have the same issue, when I choose to view medium icons it show the default Unreal icon but another size shows my game icon.

“When I open my program exe (WindowsNoEditor\ITA\Binaries\Win64\ITA-Win64-Shipping.exe) using visual studio, there are two icon files attached. One has just my 256x256x32 bit png icon in it (correct). The other has a composite icon with not only mine, but also the default Unreal icons at 24x24, 32x32, 40x40, 48x48, 64x64, and 256x256. Depending on if I set the view in windows to be Extra Large, Large, Medium, or small icons I get either mine or unreal’s icon. This is despite the fact that the icon file I specified in my project settings has my icon at all those sizes. The build process is apparently copying the 256x256 version of mine icon into the unreal default icon file, but ignoring all the other sizes.”

I refer you all to my answer to this question at the bottom of the page:

Basically, you need to make sure that your icons are created with the standards for Windows and then it should work fine.
I’ve created a step by step guide on how to do this.

Your icon isn’t built correctly then. See my answer below.