I need help remove android permissions on my oculus quest 2 game trying to submit

AppLabSubmissionProblem.pdf (357.7 KB)
I have a problem with removing the android.permissions while trying to submit my game to app lab. I made an Oculus Quest 2 game and here is what is happening. OK, when trying to upload it through Oculus developer hub, I get a note that says my manifest includes android permissions and if I am not using them, I need to remove the permissions. I tried a lot of different things but I can’t seem to get it to remove the permissions. Here is an image of it.

I followed several possible solutions but nothing worked out so far. I followed this answer (from an old thread) but not sure why it doesn’t work.
Android Permissions Problems - Platform & Builds / Mobile - Unreal Engine Forums

Here is what I did, I added the code to the files that he said but I noticed that what happens is the files that I change…the .build.cs file gets overwritten when I package the project in UE4. I am using a Blueprint project because I thought it would be a good idea since I heard that blueprint encapsulation is good for mobile. I am modifying files in the intermediate folder so I wonder if that is the problem. Because it keeps getting overwritten.
When I submit it I will need to remove the permissions but I can’t get anything to work. Does anyone know how to remove permissions for app lab submission.? Thank you!! I will look for a .build.cs file somewhere else in the meantime.

here is my remove android permissions file

Here is my .build.cs file

I was able to fix this problem. Because it was a blueprint project the source folder was in the intermediate folder and it kept overwriting it. I converted my project to c++ and then the source folder was in the right folder and everything worked out.


You can also just write your changes in your project setting. This would seem to be a lot quicker

1 Like