I lost a drive with ue4 on it, now the installer won't run

hey, i lost a secondary drive which had my working install of ue4 on it. now when i run the installer, it says *the folder path ‘Unreal Engine’ contains an invalid character.

i went to uninstall ue4 in programs and features, and recieved the same message. the old drive was labelled F

i’ve tried deleting all the stuff in C:\ProgramData\Epic , but i get the same result. i’m stumped, any ideas?
i’ve tried uninstalling ue4 from programs and features, which gives the same error

tried running the command that you guys are reccomending to other people with installer problems -
msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt
(moved the installer appropriately and renamed it)

and im getting an error -
error opening installation log file. verify that the specified log file location exists and is writable

worked around this - got a friend to upload the installed launcher, which has run properly and i can install a version. will find out if it works.

Howdy stranj,

Just wanted to check in a see if you got the installer running for UE4? If it is not, please do let me know so that I may further investigate the issue.

Thanks and have a great day!

No, i didn’t solve it, i worked around it as described above. was able to install all versions fine after i manually copied over the launcher - HOWEVER, in trying to connect to a multiplayer game on the same ue4 build - from the PIE game, we’re getting some logspam which includes request the client to upgrade or downgrade bgetwinnetversion - scuzi i’ll look up the actual syntax when im not at work.

worried that this may be a symptom of not having had ue4 install in an orthodox manner, like maybe some support software didnt get installed right.

we CAN however connect fine between identical packaged installs of the same project.

Correct me if I am wrong, You are saying that you are not able to connect when using the PIE mode? Are you able to connect using the standalone or packaging the project and playing that way? Just want to clear up what you have said in the previous comment.

Thanks!

Hey stranj,

Just wanted to reach back out to see about the issue that you have reported. If you could help with the information asked for in the previous post, it would be greatly appreciated. Please also let me know if you have resolved the issue so that I may close out this post.

Thanks!

hey Sean thanks for your follow up.

i my suspicions were unfounded - the other guy just forgot to update his source control and we’re now able to reliably connect with eachother using PIE.

however, even though i successfully used that workaround mentioned above and got ue4 installed, the actual installer still won’t run. it now gives me a different error “invalid drive: F” then goes to the *the unreal engine installation ended prematurely (finish) " dialog.

the F drive is the one that died, and at no point do i get the chance to change the installation target. something has been stored on my machine pointing that installer to the now nonexistant drive, and the installer seems to require that this drive exists before it will give me the opportunity to change the target.

I looked up a couple of previous issue where users where seeing the same issue. They seemed to have resolved the issue by either fixing the invalid driver and re-installing the engine. There was also another user who moved the install file over to there local drive and just changing the install directory to their external drive. In both cases, you would have to be sure that all traces of UE4 are out of your all drives and then re-download the installer.

well i can’t fix my drive, it’s dead. i moved the installer .msi file to the c drive and it gives the same result.

i’d like to reiterate that this fail happens before i have the opportunity to enter an install directory. i run the installer app, i allow it permissions, and it gives that error.

as for removing all traces of ue4 - where are they? i found some in documents, i found some in program dir, i found some in appdata, removed all those and it changed nothing.

can’t run the uninstaller - its the same application and it gives the same error.

Would you happen to have a firewall or an antivirus application running on your PC while you are attempting to install UE4? This could be preventing the installer access and thus causing the error.

Hi stranj,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

well i worked around it and i don’t have the opportunity to attempt to reproduce it. as long as you guys make the launcher available as a download somewhere other people will be able to fix this in the same manner. as for the antivirus.
thanks for your help on the issue.

Thank you for the update stranj. If this issue appears for you in a future release, please be sure to open this post up so that i may further investigate. I will also be sure to point users to this post as it provides a workaround for the issue.

Thanks and have a great day!

I’m still getting the same error for the path having a invalid character even after removing all data of unreal engine and using a secondary drive to try installing.

Hey Firemelon-

Could you elaborate on what you’ve tried so far and what exactly is happening when you try to re-install?

I’ve removed every unreal engine folder I can find and then I try to reinstall the launcher and I get the same original error above, which is there is a invalid character in the folder path.

Where was the engine installed originally and where are you attempting to install it now? Does the error message say what the invalid character is (period, comma, backslash, etc.)?

This is my process to try to install:

step 1: Screenshot - 54358a6363ee228b8afab301df523911 - Gyazo

step 2: Screenshot - 983fc5b749baf57715626b201cb9c177 - Gyazo

step 3: Screenshot - 5e8dea02fb61a9305677232dafed8536 - Gyazo

step 4: Screenshot - f319b1151f0a419a010b1f54515868d5 - Gyazo

Getting same problem here as pictures above. Expect it’s The folder patch ‘Program Files’ contains an invalid character. I lose a drive with ue4 on it and now I can’t install.

I did try running this was able to get the txt file. msiexec /i d:\EpicGamesLauncherInstaller-2.5.2-2717637.msi /L*V d:\epicgameinstallerlog.txt