I lost a drive with ue4 on it, now the installer won't run

What is the file path that you’re attempting to install the editor to? Are you installing onto a C:\ drive or a D:\ drive or a different drive? What exactly do you mean when you say that you’ve lost a drive?

still no fix for a software breaking bug? I can’t even uninstall unreal engine anymore because it gives me the same error

Hey Firemelon-

We have not been able to track the cause of this problem so we’ve not been able to formulate a solution. Just to make sure I understand correctly you are getting this message when trying to install the launcher, correct? Do you get the same error if you download/build the engine from source? At what point in the install process does the error occur? Does the error occur before or after any input from you (choosing install location, folder name, etc.)? If you get the message after choosing default location, are you able to remove any spaces in the default name so that it is one word (ex: EpicGames rather than Epic Games)?

Cheers

Doug Wilson

I literally posted the exact steps I take trying to install with pictures of each step 3 months ago and no one replied to them and you keep asking questions that don’t matter because it doesn’t allow me to do anyhing after trying to install the launcher as seen in my above post. I download YOUR launcher, I then open YOUR launcher and it gives me the error above then ends the install process and like I said earlier I can’t uninstall the unreal engine program because of the same error.

Here’s a clear explanation of how to end up in this state:

  • Install install EpicGamesLauncher to “F:\Games\Epic Games”.
  • Remove your D: drive (In this instance, have it catch fire, or whatever).

Symptoms are:

  • Uninstall does not work - Cannot find F:\
  • Running the installer does not work. - Cannot find F:\
  • Restoring from backup to a location on C:\ allows a few things to work, but no updates.

Things required to fix this:

  • Search and replace across registry to replace all references of the old path to the new path - there are a couple hundred.
  • Search and replace across registry for the old drive letter “F:”. There are two hex keys with this.
  • Edit C:\Users\Me\AppData\Local\EpicGameslauncher\Saved\Config\Game.ini to show new path - one line.
  • Update all of the shortcuts in user and all users Start Menu dirs.
  • Restore any backups you might have to the new path.
  • If the Launcher is still missing, uninstall and reinstall from control panel.
  • It the Game.ini path is roast, then use the EpicLauncher to uninstall, repair, or reinstall.

NOTES:

  • Default path is “C:\Program Files (x86)\Epic Games”
  • Most of the registry entries were in HKLM, but some were scattered all over.
  • Also, regedit33 in adminstrator mode could not find them all. I had to go one by one in MS’s regedit.
  • It is possible you might be able to just fix the uninstall path location in HKLM\SOFTWARE\CurrentVersion\Microsoft\Uninstall{######}, but this did not update all of the registry entries for me.

Based on the screenshots it appears that you first double click on the launcher.exe followed by Run. Is there any other input before the third screenshot of the error message? What is happening in the install process prior to the third screenshot? Also, can you try the steps that xaminmo mentioned to try to fix it?

For someone that understands what you are saying and wants to do it but doesn’t know exactly how, is there a way for you to make a quick video or post step-by-step images explaining how to change the files paths. Thanks!

nothing happens in between those screenshots literally that is all YOUR software allows me to do and I have but unlike him I don’t know exactly how to find every single thing I need to delete to fix YOUR software that is still broke, and I just bought paragon and instantly regretted it because YOUR software is still broke and you still can’t fix it or provide a patched version to install to fix it.

fixed it disregard last post