I have followed your installation guide on the toolkit for Maya, but it won't show up?

I have followed your installation guide on the toolkit for Maya, but it won’t show up?
I put the userSetup.py file inside the scripts folder in Maya, but I can’t access it.

Hi EmilOgard. Which step in the installation instructions is giving you trouble?

None, the toolkit just don’t appear in Maya. Is there anything other than putting the .py file in the scripts folder I have to do?

After you moved the userSetup.py file into your maya\scripts folder and restarted Maya, did you get the dialog box asking you to locate your Maya Tools directory, and did you point that to the UE4/Engine/Extras/Maya_AnimationRiggingTools folder where the userSetup.py file was originally located?

If you did all of that correctly, I am not sure why you are not able to see the Epic Games menu in Maya. Try deleting any instances of userSetup.py that you have in your scripts folders and go through the process again as outlined here. If that still does not work for you, please let us know.

I did not get that dialog box when restarting Maya.

@EmilOgard

What version of Maya are you using?

I am using the 2015 student version.

We have not yet performed testing on Maya 2015, therefore we cannot guarantee functionality or provide support for it at this time.

There are also known issues with the Student Editions of Maya (for 2013 and 2014 versions), which did recently get some fixes.

Please view this forum thread for additional information and a link to the latest script, which might be able to help you.

Animation and Rigging Tools: FAQ, Known Issues and Feature Roadmap - Character & Animation - Unreal Engine Forums

Cheers

I just tried the same in Maya 2014, and it was not working. Makes me think I did something wrong. I copied the userSetup file, and pasted it in C:\Users(MyUser)\Documents\maya\2015-x64\scripts. Is there something I may have done wrong?
When I launch Maya, the box that appears besides the program said “failed to execute usersetup.py”.

Is there a clear answer for this? Im using maya 2013 and having the same issue

Hello,

I have previously provided a step-by-step guide in this other post. Please refer to it and follow along closely.

How exactly can I install the animation and rigging toolset - Character & Animation - Unreal Engine Forums

If you have followed every step and are still experiencing an issue, let us know and we will continue to investigate.

Thanks

Hi, I have tried several times now, and it doesn’t work. Not in Maya 2014 either. In the instructions it said I should have to overwrite the old userSetup.py file, but there wasn’t any. I’m adding a screenshot of the error Maya gives me.

@EmilOgard

Apologies for the delay. I have brought this issue to the toolset’s creator to see if he has any recommendation.

Can you give the userSetup file located in the dropbox a try?
userSetup.py

Just copy this one over your other one and see if that settles your problems. You’ll need to restart Maya for it to take effect.

Thanks!

It didn’t work either. Maybe I’m doing something wrong. I installed Unreal Engine 4, and Maya, copied the file to documents/maya/scripts and nothing else? Am I missing something?

Hey there!

Sorry to hear that didn’t work out either. I made a video going over the install process. I hope this clears everything up and helps track down the issue!

Installing_ART.wmv

Thanks for making the video. It helped a lot.

I’m having the same issue. I followed the video and PDF instructions but the UserSetup,py file will not launch. Please help. I need assistance ASAP!

Using Maya 2016 on Mac.

72610-1.jpg

Hey there!

The userSetup.py is not a plugin, but rather a python file that needs to go into your maya/scripts folder. That’s all you need to do. Once you open Maya, it will ask you where the tools directory is, and then you point it to the location on disk, and you’re off to the races! There is a video up above I made. It should be valid still, though it was recorded on Windows.

Cheers!

Hello Jeremy and Ben,

Thank you for the response. I have followed the instructions and video tutorials without any success. I understand that the file is a script and it belongs in the Maya/Scripts folder. I have placed it it its correct location but always receive the userSetup error that I showed above.

I have read through quite a few forums regarding the issue with no solution explaining why this is happening. I have even checked all of my Python files named userSetup and there aren’t any. I’m really stuck on this and has halted production for me to animate characters on a game using the Unreal Engine. Help please!