Download

I have a black background in my viewport, but when I render an image, an hdri map appears.

I have this viewport. Look at the picture:

This is my World Outliner. Look at the picter:
2021-03-22_145725

But when I do a render in the sequencer window using “Cine Camera Actor”. The result is something like this. Look at the picture:

An hdri map appears from somewhere.
How can I disable this map? Or how can I render so that the result matches what I see in the viewport?

That’s kinda wild but not really.
The HDRI is probably there to be able to get Reflections to render something.

Between the 2 shots, your exposure is changing. Probably why the hdri is becoming visible.

Edit the post process and either disable eye adaptation, or modulate how much eye adaptation is allowed.

As far as how that hdri appears, no idea.
Create an empty level. Add the sofa. Add the lights. And render. Shouldn’t have the image unless you add it in.

Thanks for the answer.

I’ve already solved the problem. Here’s the solution.

The fact is that in my scene there were several levels downloaded from one lesson on YouTube.

I’ll tell you what levels are.

In Unreal Engine, the levels window is used to optimize the game. As I understood with this tool, it is convenient to load objects visible to the player into memory, and it is convenient to unload objects invisible to the player.

The eye in the levels window controls the display of levels in the viewport.

The display of levels for the camera that renders an image is controlled via the streaming method or through special “level streaming volume” objects inside which the camera must be located in order to see one of the levels.

It seems that there are other ways to control the display of levels.

So in the viewport, the display of all the levels was disabled for me, but one of the levels in my scene had the Streaming Method set to “Always loaded”.
Because of this, the camera in the scene when rendering saw this level and all the objects in it, and in particular the hdri map, spoiling my rendering.

Changing the streaming method to Blueprint solved the problem.
image