I get an error everytime I try to create a C++ project

An error occurred while trying to generate project files.

Running D:/UE_4.18/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“U:/Users/Anıl Yıldız/Documents/Unreal Projects/MyProject/MyProject.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
While compiling D:\UE_4.18\Engine\Intermediate\Build\BuildRules\UE4Rules.dll:
ERROR: error CS0016: Could not write to output file ‘d:\UE_4.18\Engine\Intermediate\Build\BuildRules\UE4Rules.dll’ – 'The directory name is invalid. ’
ERROR: UnrealBuildTool Exception: Unable to compile source files.

This is the error I get when I try to create a C++ project
I tried reinstalling VS2017 and UE4 and it still gives me this error

My best guess is file system name encoding issue, but it looks fine for me. Try deleting Intermediate directory that error mentions, if still not work and you get something else then “Verify” your engine installation in launcher (i assuming you using launcher version). If this does not work, then google error code CS0016 and try various solutions that you find there

I solved it by uninstalling everything epic games included and reinstalled it. It works fine now. Probably one of the pre requisites didn’t installed correctly