Download

I cant Package my project for android, It just opens the unreal documentation website

Every time I try to package my project for android, it just opens a new browser tab and goes to the unreal documentation website, there are no errors or anything as the Engine doesnt even attempt to package the project. If tried closing and opening the project, restartingmy computer, and uninstalling and reinstalling unreal, same result every time. This is a Blueprint only project on Windows 10 and Im running Unreal 4.24.2. any help would be appreciated

That happened to me too, it is when its c++ project. Check below

https://forums.unrealengine.com/comm…ging-wont-work

What about log in log folder?

Did you install the Android SDK on your PC? From what you mention in your post it sounds like you missed this step. To learn how to do this, check out the following link:

I did in fact install the android sdk, ndk, and java jdk, and added them to the project settings.

This is NOT a C++ project, Blueprint only, no C++ or even any plugins being used.

It looks like theres a new update for 4.24, hopefully thatll fix it, ill let you all know how it goes.

I just updated to 4.24.3 and i can confirm this problem is still happening

Try https://docs.unrealengine.com/en-US/Platforms/Mobile/Android/InstallingAndroidCodeWorksAndroid/index.html

it turns out i didnt have the editor set tot he right location for the sdk ndk and jdk. Instead of just giving an error, it automatically opens the unreal documentation website for no reason. That was the problem it got resolved. Thank you though]\

In my case, deleting all ‘Intermediate’ and ‘Binaries’ folders, includes plugins, that works for me.

BTW if anyone stumbles on this page, heres how to do it in 4.24. https://www.youtube.com/watch?v=3Imqb73WVeg
Ill be posting another tutorial tonight on how to do it in 4.25

and heres the video for 4.25 https://youtu.be/7c2L3OjabV4

I came here b/c I had the same issue. You will only need to restart Unreal if you make changes to the project settings (for ex: android SDK/NDK locations, etc) because those settings load with the project.

Also, it is probably better to leave the settings blank that pull from the Windows Environment Variables values. As you update any one of these pieces of software, it is highly likely at least one of these entries will be stale. Instead, pulling from the Environment Variables will (or should if done right) guarantee a successful configuration setup every time the engine is loaded even after upgrading, say NDK.

1 Like

Deleting the intermediate folder worked for me in 4.23

4.25.3 Same thing, my sdk jdk and ndk are the correct versions, the editor knows where there are. But when i try to build, unreal editor opens a web page that is unreal 101.
That’s completely unhelpful.

The url has something about android in it, but obviously your url is wrong.

I’m having the issue in 4.25.3 as well. I’ve followed along with ViceVersa and all the other documentation that seems available. Everything set fine, I was able to package the project once. Since then, every attempt just opens the URL.

logout below:

[2020.08.29-23.53.49:862][990]LogUObjectHash: Compacting FUObjectHashTables data took 0.43ms
[2020.08.29-23.53.49:864][990]LogWindows: LaunchURL http://docs.unrealengine.com/latest/INT/Engine/Tutorial/Mobile/SettingUpAndroidTutorial.SettingUpAndroidTutorial/index.html

The solution that worked for me was to run updatelinker.bat which is stored with the setupandroid.bat file in Engine\Extras\Android.

[FONT=Times New Roman]I also had this situation at the beginning, but after I tried to manually modify the SDK config for many times, the problem was solved. I think it should still be the SDK config . Please refer to my SDK config path, hope it will help you :slight_smile:
in 4.25.3

Screenshot 2020-09-14 074256.png

@blackmoon4 pushed me to the right point, ev. with all before tried for 4.25:

Deletes binary, intermediate derived cache directories, rebuilt visual studio files restarted, changed android sdk setting like above.

Then also set NDK to the ndk sub directory as in the screen seen from @blackmoon4

Still had the webpage open on package.

A a last step in my trial and error I replaced matchndk entry to latest.

That stopped the web page and opened the packaging folder dialog, now my project is packaging.

Thank you!

hey im gonna post another updated tutorial on youtube for this in 4.26 in the near future.
but heres how you make this work

First of all, ignore every thing you see on the unreal website its very outdated and no longer works
if youre going to put anything on the google play store it has to be android version 29 or higher (current is 30 but idk if that one actually works in unreal yet).
so, you need to download android sdk for version 29 from the sdk manager, download ndk and cmake from the extras section,
you can run the bat files in the extras folder, but they will still download a bunch of outdated sdk stuff as well
if your path for android sdk ndk or jdk has certain non alphabetic characters, this will not work and the error messages will be confusing (so if youre in a country thats not english speaking that can be a big deal).
when you set the sdk location in unreals project settings, you need to go to the platforms folder, then go to the android sdk section and click I agree to the terms and services, then go back to the android sdk section and set it to the sdk folder, then go back to the android section in unreal and click i agree again, this time the button will turn grey
make sure in the android sdk settings and android settings, anything that asks which sdk version choose latest, if it asks for a number set it to 29.

this is the best advice anybody is going to give you. follow the instructions and it will work every time.

I just found this out the hard way but you have to update the android sdk entries in the project settings

I was having the same issue. I read somewhere that if you left the path (i.e. “Location of SDK”, etc.) blank it would use the default path. I was confident that my SDK and NDK paths were correct, but was suspicious of JDK path. I decided to leave the JDK path blank and the problem went away – i.e. unreal was able to find Java.