I can not have nice textures..please !

Hi !

There are a few times, I posted a topic but I have not fully understood the answers. I work with Substance Painter and the result is stunning !! However , it is always the same, textures become ugly on Ue4. I know if it comes from Substance Painter or Ue4. Here is an example:

(Substance Painter)

And on Unreal Engine 4, I do not have all these depths effects etc.

Please help me step step. :frowning: :o

Thank you a lot.

You will have to create a proper material for your mesh → so export your textures - import them - create a material - add different effects (normal map, tessellation, reflection,… ) :slight_smile:
Depending on the textures that you have (normal, specular, displacement, diffuse,…) I can post you a step by step explanation

1 Like

Yes I did all that, but I get strange textures, here is an example.


I do not know where to put everything,and even if I find, I’m sure it will be ugly and I do not know why there’s a black line on the texture

Looks like a uv and lightmap problem. Are you unwrapping your mesh and texturing it properly?

I just unwrap UV, not lightmap.

You need a good lightmap. After you make a good lightmap and import your (mesh make sure you uncheck make lightmap on import) you can increase the resolution of your lightmap to 512 or 1024 that should clear it up. Then it’s all material parameters.

Another thing, I don’t think you need an image texture for the orange bits, you should be able to just make a material in UE4 for that. Just assign a place holder material in your other software.

Ok, thank you it starts to look like something but where can i place base_height ? Now i’ve another bug:
bug.PNG


even if we begin to see relief, is missing.

I would take off the textures for the orange and just use a orange diffuse, a constant for the roughness (not a texture) and a normal map for some texture.

OK, I see what you mean

Hello

In substance Painter you should bake your maps in a higher Resolution, as you need. Especial the Normal Map needs to bake with
higher resolution and 4x4 subsampling.
In UE4 You always must use DirectX.
Set roughness and metallic to greyscale.
Be sure to select the Option to “compute Tangent space per Fragment” when building a new Painter File.
Set the export resolution to 8 Bit PNG and the normal errors will be solved.
Your unwrapping also has extremly waisted space. Before texturing you should optimize your UVs.
Hope i can help

Maybe try the Substance Plugin for UE4? You can import the substance directly.

Ok i will try what you say and i will test plugin. @srmojuze

Try test i’ve got a good result, i will modify the uv mapping to have a good shadow and it’s perfect ! ?

Great, so using Substance Plugin and/or cleaning up your UV Mapping you will have a good result :slight_smile:

I don’t think Substance Painter produces *.sbsar files to use with the plugin.

Good point. Until then apparently they recommend going from Substance Painter into Substance Designer (then into UE4 with Substance plugin).