I can Export Skeletons mesh from blender to Ue4

It all working to put it in FBX but why I try to hit import in Ue4 It is saying : No smooting Group Information.

Oh and I Just can Add a picture It just wont dowload so could you help me with that too.

Hi, the max picture size is 5.2MB and you can upload a max of 5 images.

I’m using blender 2.80, this setup worked for me: So Object → Shade Smooth, then under Normals check Autosmooth and set the angle to 180 (so you would mark any edge you want to be sharp manually). When Exporting the FBX under Geometry set Smooth to Edge and check Tangent Space (this only works with tris/quads you may have to apply a triangulate modifier to your mesh). Then when you import the mesh into unreal import the normals only and generate the rest.



It also works in 2.78, I just tried it

Well I have blender 2.78 soo …

okay thank you I will try

It worked but Now It is saying that: Multiple Roots are found in the bone hierachy. We only Supports single root bone.

In the export settings under Armatures did you uncheck add leaf bones?


I uncked it but It still says multiple roots are found in the bone hierachy. We only support single root bone. Was I suppose to unckeck the add leaf bone ?

Can you show an image of your armature hierachy?

were is that ?
Could you put a picture

it will be in the top right of the screen in blender. basically where all the meshes and things are listed there will be a group for your armature/ skeleton. multiple roots will occur when you dont just have one skeleton (more that one bone heirarchy).

Okay thank you I played with the FBX setting in blender and in ue4 and It worked but not the way I expected. If I understand well all the bone or part are all separated so Is there an option too regroup them or something ?

yup thats blender. top right where it says scene, go to pose which should list your bones and check the heirarchy there. also when you export make sure that mesh and skeleton is the only thing selected then try the export selected option ( i think thats what it says been awhile since ive used that version).

Do you only export the mesh and the armature, or do you have animations too? When I export animations I uncheck those two settings, else blender seems to export each action seperatly.


the only reason i can think of for your skeleton to separate like that is if you separated the hierarchy so its importing each bone as a separate skeleton. what you need to have is a mesh and a skeleton (singular), the skeleton should be made of a hierarchy of bones that have as a base a single bone(the root- usually pelvis or a specific root bone).

the smoothing group error isn’t really a issue its more of a warning. if all else works then i wouldn’t worry about it too much.

okay and how can I fix that