Download

I add water but nothing shows.

I just started UE 4.26. First test, I create a new project. Open a scene, add the water plugin. Then I plop in the ocean. I see the spline, no ocean. I get squat. What gives?

First learn using Unreal Engine, spend a few months. Knowing how to add an ocean won’t give you anything now since you won’t be able to make anything with it. Also, you don’t need to test anything, it is all already working. If you are testing to see how it looks you can watch how it looks on youtube.

@Joebobjenkins Did you also add a landscape to the map? The water system is tightly coupled to the landscape system and won’t really work without it. Here’s what should make it work:

  • remove the water volume from your level
  • add a landscape and make sure “Enable Edit Layers” is activated on the landscape actor. If you don’t see the option you might have to enable the Landmass plugin first (not sure about that part)
  • add the water body to the level