Download

Huge shadow depth render time, help needed.

As the title says, there is a huge, and i mean huge (500ms) render time for shadow depth in some areas, and i don’t know what to do, screenshot with gpu profiler attached below. https://drive.google.com/file/d/11tWGXPzeBSjsDgbK0DIxKiKARDDWvM5P/view?usp=sharing
i tried looking at all the optimization view modes and everything is fine, this issue hasn’t appeared before even though i have used the assets heavily. Need help figuring this out, please tell me if you need any more information or screenshots. Thanks in advace!

You need to build your levels lighting as right now everything is casting a dynamic shadow. You can read more about how to do this in UE4 using the following links:

https://docs.unrealengine.com/en-us/Engine/Rendering/LightingAndShadows/Lightmass

https://docs.unrealengine.com/en-us/Engine/Rendering/LightingAndShadows/Lightmass/Basics

thanks, but this never happened before, now every time i move something i get 2 fps and have to wait for a 5 minute build? There must be more to this…

also ,my directional light and my skylight are both movable. The only static lighting i have in the scene are point lights. I paint foliage somewhere far away, that does not touch the point lights at all (attenuation radius is very low), and i am sure they are not touching, and then i get lighting needs to be rebuilt error and 1000ms rendering time on shadow depths. Something feels very wrong.

I’d try deleting/disabling all lights and check performance, enable just the sky light, test again, just directional, etc.

If yo uare using static lights you have to build your levels lighting as that is how static lighting works.

2 FPS is indeed very extreme.
How many lights do you have?, and how big is the level you are working on?
1 thing to do, is check the attenuation/radius of your point lights is not bigger than it needs to be.

To help us help you more, type the console command “stat SceneRendering” and send us a screenshot.