Huge random performance drops in Unreal Engine 4.11

Hi, I’ve been occasionally having huge performance drops in all my projects after converting them from v4.10 to v4.11. It has happened a few times in packaged products as well after restarting levels, even though everything was running fine in the editor.

I have tried removing all actors in the scene including the lights & it still performs very badly once it occurs. Tried reverting back to older nvidia drivers & still had no impact.

I really don’t know what’s causing the issue, but when it happened today, I closed my project & created a new blank project in v4.11 immediately. And it’s present in the new project as well. Since I’m not sure if it will happen again after a system reboot, I’ve taken a couple of screenshots and kept the project as it is in case the log files might of some use. Here are the thread stats & basic overview of the GPU profiler when it’s occuring:

Even going around the level in the editor window slows down. So removing the Unreal Engine application from the Task Manager & then restarting seems to be the only direct way to get the editor running properly again.

Hi Stormrage256,

After working with a user with a similar issue here:

…It appears this only occurs when you convert a UE4.10 project to UE4.11 -but not always, thus making it difficult to pinpoint the cause. As stated in that post, we typically suggest finishing the projects in the same version of the Engine they are started from and only updating if there is something added that is critical to your finished project. If you do need to update, always open a copy of the project in the newer version in order to isolate issues caused by updating more easily. Also, if you are in the early stages of a project and want to update to UE4.11 you might want to try migrating the assets from UE4.10.

That said, if you are experiencing performance issues consistently in newly created projects in UE4.11, please provide steps to reproduce the issue on our end and post a copy of your dxdiag in order for us to effectively isolate the issue.


I have the v4.10 backup files for all the projects, so that’s not an issue. However, most of my projects are products in the Unreal Engine Marketplace & hence I don’t have much of an option not to upgrade them if I want to offer support for the latest version.

Since it’s happened in all my projects even though a couple of them are completely different from each other, I’ll see if it’s possible to repro it in one of the default templates during conversion. In any case would the log files from the bugged instance of the project be of any help in this regard?

Yes, in addition to reproducing in a default template if possible, please supply the logs from the bugged instances as well as your dxdiag -thanks

*Also, in which projects that you have on the Marketplace does this occur? I can get someone on that team to run tests using those assets.