Huge quality loss with Nanite?

With nanite on most of my meshes degenerate. Am I pushing it with 1,232 triangles? :smile:
Any idea why? I don’t recall seeing it as much in Early Access.

UPDATE: Found a screenshot of a wheel to compare with Early Access.

1 Like

A Nanite mesh should look exactly the same as the non nanite mesh. If it looks any different, it’s because unreal engine is falling back to the proxy mesh that nanite generates.

Make sure that the editor is running in DirectX 12 mode, if it is try updating windows and graphics drivers.

Hmm, updating my graphics driver didn’t do it.
What do you mean by DirectX12 mode?
To my understanding Nanite should be good to go by default.
It does seem like it’s stuck on these proxy meshes.
It was (mostly) fine in Early Access.

If you hover over the project name in the top right bar of the editor, it’ll tell you if you’re using DirectX 11 or DirectX 12. With 5.0 Nanite was changed to DirectX 12 only. You can also use the Nanite debug views to see if it’s working at all under the viewport lit options.


Ah, that was it.
Top-right bar said DirectX11.

For anyone finding this it’s:
Project Settings > Platforms > Windows > Default RHI: DirectX12
(it was set as Default from Early Access)
If the editor freaks out after relaunch like mine did, just relaunch again.