Download

Huge map difference between 4.13 and 4.16?

Hi all,

Had a map that got started in 4.12 or 4.13 (can’t exactly remember) and my guys finished it off completely in that version. When I import the map and all the assets into 4.15 or 4.16, it looks drastically different. They think it’s some way UE changed their post effects, but I can’t find it anywhere and I’m not sure what to do. Any advice?

4.13 Version

4.16 Version

Hey,

Try disabling the filmic tonemapper (Enabled by default since 4.15)

Open console and type r.TonemapperFilm 0

That made a very small difference (though slight improvement in color for sure). Any other ideas? thanks!

I assume you’ve checked the directional light intensity to make sure it’s actually the same?

By the way, your game looks beautiful.

Technically, you are not disabling the tonemapper but reverting to the legacy one.

Admittedly, I’m just the producer basically, not the level designer. Can you guys tell me in idiot’s terms? :smiley:

Helps a little thanks for info! Facing same situation struggling in 4.15 upgrading from 4.10.
Tried 4.14 too on the way and it looked even worse! (Using r.PostProcessAAQuality 0 also).

Overall just finding it far harder to match screens from the two different engine versions etc.
Having to use many more PostProcess tweaks to get things looking better, but still not great.
The worst part is Split-screen though, as PP drops completely, and the result is really awful!!!

Any other tips / tweaks very much welcomed…

This really highlights why the old tonemapper needs to remain an option going forward. That’s a pretty noticeable difference between only 3 engine versions. Options are fine, but removing it completely isn’t fair to developers who are going for a specific look.

Bump. Still haven’t found a fix.

I don’t see that much bloom in that szene so probably you could workaround with LUT color grading in that case. Just created in a few seconds as an example that brings back more saturation at green, a bit more red at shadow … a bit more yellow at mid and blueish at highlights so it should look more similar to the old screenshot
LUT-example.png

You have to add it into Color Grading → Global-> Color Grading LUT of your PostProcessing volume (that is set to unbound or that one of your cam)… and don’t forget to mark that “ColorLookupTable” at TextureGroup at texture (or it would look horrible).

However… I would prefer the behaviour of the old tonemapper (bloom). I really miss it.

I can’t find this piece. Currently looks horrible and I’m guessing that’s what I’m missing :smiley:

It is in the texture settings (double-click the texture in the content browser):
23520de272fa5114f2becb01d6d299eedf8d51ce.png

I’ve just created this quick in Krita. Usually if I make LUT I make a screenshot of more than one cameraview …including characters and some highlights and dark scenes so I get a better idea how it would affect the hole game… merge all those screesnhots together and start playing around with all those color balance, color adjustment curve, dodge and burn filters… exporting only that rainbow like 256x16 image at top left.

Ah found it, thanks. That definitely looks loads better, but still not as good as my original. Am I just **** out of luck? I really don’t want to have to pay someone just to get it back to it’s old glory on the new engine version.

I don’t know a way how to get the old look back… as many others don’t know it currently as well. Epic did not give us a solution or how-to yet. There are various threads regaring that issue. The new tonemapper could look better in realistic szenes but turns around the emissive colorwheel way too quick and even on the bloom colorwheel which is less than before and even another color. Probably they did that to make the path ready for upcoming HDR monitors but actually it’s counter-productive for art that should be displayed on mainstream monitors and should not look like a photo. You would like orange emissive with orange bloom - and don’t give that much if this is physically correct in terms of a colortemperature of a black body? In a comic this is no issue… as well in any fantasy or sci-fi theme. With the new tonemapper you get white emissive with little yellow bloom instead. So you have to tinker around a lot and usually the most solutions affect the hole game. It’s more difficult with bloom as everything starts “bloom-bleeding” that way (if you increase bloom for example). Your issue seems a bit more like “tuning the color temp at a monitor”. Probably you could tinker a bit more with some different LUT textures (as I wrote I just tried a few seconds based on those two screenshots you posted) and get a better result if you try a bit longer. But I’m afraid there is no “make it like < 4.15 again” switch.

https://answers.unrealengine.com/questions/565285/howto-neon-light-material-with-new-tonemapper-in-4.html
https://answers.unrealengine.com/questions/581853/how-to-configure-bloom-in-415-to-look-like-in-4143.html

Bump as I’d still like to avoid having to pay someone to completely re-do the map.

Choose one:

  1. Use the color grading tools in the post process until it looks good for you again.
  2. Pay someone to fix it for you.
  3. Go back to 4.13.

The new tonemapper shouldn’t have that large of an effect on your project(at least in this example). It encodes the scene referred linear color in a wider gamut and gives more room for varying display types when it converts back to the user’s display in sRGB. If anything, your colors should be a *tiny *bit different in saturation(with the exception of the blue primary issue in current ACES), whites brought down a bit so you get more room, and blacks brought up a little and potentially clamping if you don’t follow standard Albedo color ranges.

4.15 did bring a lot of post-process changes though, most notably the bloom threshold being more physically accurate. It’s possible the earlier version of your map was relying on a warm bloom to fill the scene, and with the new threshold the brightness values don’t contribute to the bloom so you’re left with the cool temperature scene. I’d look at and compare the post-process settings to make sure the color grading is identical(including the look-up table if there was one before). For a quick fix, you could look at the Temperature control in the post-process to bring back some of the warmth.

Before you modify anything though, I’d also make sure that your viewport is set to default settings(in viewport, Show > Use Defaults), your exposure is using the provided values in the post-process(in viewport, Lit > Exposure > Automatic(Default in-game), and your editor scalability settings is at Epic(above viewport, Settings > Engine Scalability Settings > all to Epic). I run into a lot of issues at work where people accidentally or for some unknown reason have certain things disabled in the viewport, so the first thing I always do is reset their viewport and make sure no low-quality settings are what’s breaking anything.

Edit: Also make sure that all textures carried over. See if the Skylight was using a texture or if it was capturing the scene. Same for the LUT, ambient cubemap in post-process(shouldn’t be used anyway), etc. Another test you could do is while in the old version, start disabling lights, color grading, etc. and see if you can replicate the look in the new version. That might help you track down where something changed in the conversion if something just broke.