Huge latency with Htc on 4.12 Preview


I do have a huge latency when using the both in preview and after compilation. I do not have any latency however when using it in VR editor mode.

Any way to fix this ?

Thanks !

Hello MannyLectro,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. What bench mark are you using to determine that there is more/less latency (example: FPS drop?)

From my experience (both 4.11 and 4.12 release versions) where the translational latency is not huge for me but significant enough to cause physical discomfort if i am looking for it. This issue seems to be present in all default (blueprint based) projects with the in any launch configuration, except when running the VR editor. Description of the issue from my perspective and a video demonstration of it can be found in this thread: Latency in Camera translation on the Vive. - XR Development - Epic Developer Community Forums

Edit: Upon further testing the issue seems to be related to the basic camera component you add to the blueprint pawn (be it the root object or attached to someting does not seem to matter). Activating and deactivating it causes and removes the issue.

The easiest repro steps are:

  • Create a new project/open an existing
    one with a basic pawn that HAS a camera component
    and make sure it runs at proper 90Hz
    (disable motion blur and whatever
    else you need for that etc, no need
    to tell you)

  • Play in Editor/Standalone with the

  • Notice that the world translation
    lags behind the chaperone bounds,
    easiest to notice when looking at the
    ground where the two meet. Oscillate
    your head from left to right etc. (It
    is most obvious in the case where
    acceleration is present)

  • Then uncheck the auto active flag of the camera component or delete it notice the lack of latency.
    In the video demonstrating the same where the controllers are standing still, comparing the two cases with the SteamVR overlay up as it is super obvious to visualise there. The effect is STILL THERE in pure game and can already be easily seen from the repro steps posted above, or just being close to something and oscillating the view.


Hi Rudy,

As AtsK said, the latency is present and distinguishable if a pawn has a camera component. It appears everywhere except in VR Editor mode or in Play mode without a camera on the used pawn.

I just noticed the same issue in one official VR Game, Pool Nation, done in Unreal Engine 4 too.

The latency is really obvious when looking at the chaperone grid and moving. The grid is not moving at the same speed as the game world.

Hi Rudy,

Can confirm the issue is present when using 4.12 and the pawn has a camera component. The issue can be avoided when accessing the HMD position/rotation but is obviously a workaround instead of using the pawn-camera method.

Thanks for checking on this!

Was noticing this in my own project and assumed it was me, and was going to investigate later. However, I can now confirm that I’m seeing the same cause and effect.

I get the lag/swimming when using Camera Component on my Pawn. You can see that the world doesn’t follow along as it should compared to the Chaperon. You can get quite ill while looking at this discrepancy.

If I either stop the Pawn’s Camera Component from auto activating, or turn off the Player Controller’s Auto Manage Active Camera Target, then the world in VR is locked compared to the Chaperon, as expected. The world is solid again.

This is very serious, and no VR project can be shipped in this state.

I always thought of it as the opposite, as in epics camera had low latency updating and the chaperone bounds did not, that’s why you see it swimming. And when people are disabling the camera component they aren’t getting the late update which they say fixes it but technically the latency is worse.
Although I’m not certain if anyone can prove otherwise I’d like to hear.

Definitely not !

I noticed the issue before seeing the Chaperone Grid. I simply put the headset on and went “Waow… There is some huge latency here.”. I then noticed the Grid moving much faster than the game world.

Pool Nation devs got aware of the issue because players reported feeling motion sick, not because they noticed the chaperone grid having latency.

My roomate who happens to work with me on VR stuff from time to time is really sensitive to motion sickness and before I said anything clearly noticed the issue when putting the headset on.

The Chaperone grid is rock solid, the game world is not.

Yes, I agree. You notice it without the Chaperone grid in place, it just provides a locked frame of reference. If you were to rock back-and-forth it appears that the world is slightly delayed in how it responds.

It became really obvious to me this weekend when I was sitting on the floor and looking at a fireplace in front of me (without Chaperone up). As I shifted my body, everything appeared to lag behind my movements. I was going to investigate this week why this was happening now that I moved to 4.12, and this post is quite timely.

This is affecting my game as well.

And mine, I’m having the latency swim as well. I really hope they fix this.

I was able to reproduce the issue, and good news is the fix is already in 4.12!

The issue is fixed in (also the fix is fairly simple to apply to 4.11 manually ). The issue was logged as UE-31687


The fix won’t make it to the binary version until 4.12.2, so if you want the fix sooner than later just head over to :slight_smile:

Hotfix 4.12.2 has been released but it seems that the problem persists in my project.
Do you have the same issue or i did something wrong in my setup?

The fix in 4.12.2 fixed the issue for most setups, but depending how you had your camera setup there could still be an issue. Yesterday, we put in another fix. It will be in 4.12.3. If you need it sooner, feel free to grab latest 4.12 . Here is the second fix https://.com/EpicGames/UnrealEngine/commit/1443cf5b741b669cd8c585c4e379709b35ca730b

Thank you.
I think I’ll wait until 4.12.3 and hope that fix the problem

It was still an issue in my project; can you detail what kind of camera setups mess it up? I’m cherry-picking that commit to fix it, but just wanted to know what the issue was.

4.14 and I am having the issue, PL8ptJ3R7Wc.

Can you tell us what causes the issue so that we can avoid doing it?