Download

HUD Problems - How to make a texture not repeat?

Sup mates!

So I’ve got a crosshair material (two rings which rotate). Drawing it on the HUD with Blueprint is working perfectly but the material… doesn’t work as I want it to.
Here’s a picture:

Crosshair.JPG

The textures I use for that are just the two rings (the inner one and the outer one). They are rotating around the center.
However, of course those circles are showing up in the corners again, as they are rotating.
Iirc there was an option in UE3 to make textures NOT repeat as soon as they have been drawn once. However, I can’t find it in UE4. How do it achieve that?

Open the texture in the editor. On the texture details panel, click on the icon that looks like an eye in the top right corner and check “Show all advanced details”. This should reveal the tiling options. Set both of the tiling options to clamp.

That’s it, thank you! I wonder why you’d hide such an important option in the first place?

No problem! Hopefully they’ll move it out of advanced settings in the future. You aren’t the first person to be confused by it.

I can’t find it in UE4. 24.3

1 Like