HTML5 build black screen

Hello. I have troubles launching HTML5 build. I am using latest win10 x64. Latest Chrome 60.0.3112.113 (64-bit) And latest UE 4.17.1.

After creating and building new c++ 2d side scroller project. I am getting a black screen. The game is playable. The sounds, movement, etc are working. But the screen is black.
Also, you can open the console. And I tried loading a level, through it. But all that I get is a quick splash of a level and then black screen again.
Also, I tried setting the default map in the project setting. And changing the target hardware to desktop/scalable and mobile scalable. But this gives nothing.

In attachment is the log file of the build.

log of the build

The log of the build is not necessarily too useful, but the log of the run (both in page console and in web browser console) can give better clues. It is also worthwhile to try against Firefox to see if this might be a Chrome specific issue. Do other default projects have the same issue?

Here are the logs from the browser. I tried another fresh new project - the black screen is still there.
Firefox doesn’t seem to work at all. At first, it even didn’t start the browser. And now it just straight up crashing, during first 10-20 seconds of launch. I tried Firefox nightly as well and it gives the black screen. And to make it worse it has small size :wink:

log_2

log_1

In Firefox, navigating to the page “about:crashes” will show a list of crash reports from any crashes. Perhaps it might be something worth reporting.

There is nothing that catches my eye in the above logs, except that the uniform4uiv() error, which should not happen if running in a WebGL 2 enabled browser. Are the projects somewhere available for testing? Does any UE4 HTML5 exported content on the web, e.g. http://mzl.la/webassemblydemo, work on that system?

I can open demo from the link on this system. And it works fine.

I am using default projects. Blueprint or c++. They all do the same things.

I reinstalled the engine:

The Nightly version runs but in the small window. I am able to run it from launch button. Or from packaging the project for the shipping or debug.

The Chrome version crashes on the “compiling asm.js” stage. When I run the project as packaged for shipping. Then it runs but gives the black screen. And no console this time.

The Firefox version doesn’t launch from the launch button. But the rest works like in the Nightly version.

Where should I look? Or what should I do to fix this?

Chrome has had issues recently with asm.js, due to the browser using up too much memory that it crashes. Try running by exporting to WebAssembly in Chrome, that should help Chrome to not use so much memory.

Also, if the Launch button is giving problems, you can just Package the project to HTML5, and then in the output directory, use a local web server such as emrun (GitHub - juj/emrun: Self-sufficient tools for command line automation of browser and Firefox OS tasks. Often used with Emscripten.) or python -m SimpleHTTPServer (http://www.pythonforbeginners.com/modules-in-python/how-to-use-simplehttpserver/) to quickly serve the files in that directory - that should help navigate any browser to visit the compiled code.

Receiving this same issue right now as well. Blank template, minimal default map, straight to html 5. Black screen, audio works, input seems like it works.

Same problem in 4.20.3. Html5 builds fail on default 2D sidescroller projects. Wth Epic?? Nobody is checking the 2D plugin? If we want to build 2D in Unreal we’re out of luck?