HTML5 blueprint projects don't work with plugins

When running a HTML5 blueprint project it don’t include or builds the plugins during “Launch” or “Packageing”. It works fin while using a C++ project with the same plugins.

Since a regular windows blueprint project manage to include and build during launch and packageing it wold work the same for the other platforms.

Check the log file in your browser. To make the log visible, I had to open Chrome’s DOM inspector and uncheck the CSS style “display: none” in the jumbotron element.


It’ll probably say something like it can’t find your script. If that’s the case then the Editor didn’t compile your plugin for HTML5. For the plugins I use, I had to move the plugin folder into my UE project Plugins folder from the Engine’s Plugin folder and then whitelist HTML5 in the .uplugin. Next time you launch or package it should compile the plugin into a *.bc file in the binaries folder of the plugin.

It’s a custom plugin so it’s already in the projects plugin folder. So my following question… How do I “whitelist” in the .uplugin? And do I need to whitlist both platform and target?

Open the plugin’s .uplugin with a text editor and add “HTML5” to its Whitelisted section.


Then restart your editor and package for HTML5. You should see a HTML5 folder in your plugin’s binaries folder with a *.bc file. This is assuming that that was the problem - the plugin was never compiled for HTML5 so it was missing hence why it wasn’t working for you. If the plugin was already compiled for HTML5 then I don’t know what the problem is.


I did not create the .bc file but i t worked so far (I think) :wink:


Are any of you on discord and able to have a super quick chat about this? I am trying to get socketIO plugin working after packaging to HTML 5. I will try moving the plugin to my project folder tonight and let you know. Regardless if you guys are still around I’d love to chat. Cheers

I tried doing exactly as you have said. I added the plugin to the project folder, deleted it from the engine folder, and added html to the whitelist. When I try to package for HTML5 I get errors. When I package for WIN64 it still works. Here is some of the packaging log:

UATHelper: Packaging (HTML5): In file included from D:\Documents\ChessLeague\UE4ChessLeague\ChessLeague\Plugins\socketio-client-ue4\Source\ThirdParty\websocketpp\websocketpp/connection.hpp:1640:
UATHelper: Packaging (HTML5): D:\Documents\ChessLeague\UE4ChessLeague\ChessLeague\Plugins\socketio-client-ue4\Source\ThirdParty\websocketpp\websocketpp/impl/connection_impl.hpp(228,9): error: cannot use ‘throw’ with exceptions disabled
UATHelper: Packaging (HTML5): throw exception(ec);
UATHelper: Packaging (HTML5): ^
UATHelper: Packaging (HTML5): D:\Documents\ChessLeague\UE4ChessLeague\ChessLeague\Plugins\socketio-client-ue4\Source\ThirdParty\websocketpp\websocketpp/impl/connection_impl.hpp(299,9): error: cannot use ‘throw’ with exceptions disabled
UATHelper: Packaging (HTML5): throw exception(“Call to set_status from invalid state”,
UATHelper: Packaging (HTML5): ^
UATHelper: Packaging (HTML5): D:\Documents\ChessLeague\UE4ChessLeague\ChessLeague\Plugins\socketio-client-ue4\Source\ThirdParty\websocketpp\websocketpp/impl/connection_impl.hpp(588,13): error: cannot use ‘throw’ with exceptions disabled
PackagingResults: Error: cannot use ‘throw’ with exceptions disabled
UATHelper: Packaging (HTML5): In file included from D:\Documents\ChessLeague\UE4ChessLeague\ChessLeague\Plugins\socketio-client-ue4\Intermediate\Build\HTML5\UE4\Development\SocketIOLib\Module.SocketIOLib.cpp:2:
UATHelper: Packaging (HTML5): In file included from D:/Documents/ChessLeague/UE4ChessLeague/ChessLeague/Plugins/socketio-client-ue4/Source/SocketIOLib/Private/internal/sio_client_impl.cpp:28: