Download

HTC Vive Focus

Is the Vive focus supported ?
We just got one and we wanted to por one of our projects.

Thanks
Sergio

That action could not be completed. Please try again, and if this occurs again please contact the system administrator and tell them how you got this message.

sorry something with forum. it ate my message.
Try with default VR template, at least head rotation should work, if it doesn’t then no support I guess?

Hi Sergio! Did you get it working with your own UE4 content? Thinking of getting one too. Super curious what its like to work with.

Fredrik Hellberg
Architectural Association
Space Popular

I would wait for Lenovo Magic Solo

There is a Vive dev forum with a 4.18 beta post:
https://community.viveport.com/t5/Vi…m-p/15293#M161

Inside the SDK (2.0.32) in the SDK folder…
The Unreal one is empty.
(wavesdk-v2.0.32\2.0.32\SDK\plugins\unreal)

So you have to DL it here:
https://developer.vive.com/resources/knowledgebase/wave-sdk/

Edit: “new link from June 5” Beta2 version.

The link to the beta isn’t working. Has anyone got the plugin? Or knows how to get the SDK with the plugin instead of an empty folder?

The current link doesn’t work, we reported it.

Hi! Anyone was able to launch any app? It seems to compile well, but as difference as any other android device, the app it does not autorun. I can see the UE4 folder created by the project, but no .apk inside the Focus.

It works fine today, but not from Chrome. Try other browsers.

Still doesn’t work for me, same error. I was on Firefox 57. Just updated to 60. Same.
Chrome is no go either.
Window 8.1

BUT
There is a new link, I won’t give it here as it’s for registered Vive Focus Dev (I guess)
Go to:
https://developer.vive.com/resources/knowledgebase/wave-sdk/

There is a undated link that works. (Beta2 version of the plugin)

Hello, I can’t find my app in the installed app library. Is there something to do in the project settings to make my app visible ?

I didn’t. Device Manager sees the Android Device, but every time I try to Launch / Pak I get same error. Thing I did: Codeworks uninstalled / reinstalled (CodeWorks-1R7-windows_b104), System variables reviewed, Project Settings / Paths redirected… Nothing works.

So far I dont get any error, as seems can be deployed properly. But the thing is, I don’t see it under installed app.

I installed it even copying the .pkg file to install folder and run from it. It got installed process ok, but after browsing the apps it is not there. There is something else I am missing? I activate the developer mode, I activate to be able to run no-signed apps… No idea :S

EDIT: Ok, I was able to make run the plugin sample demo.

So go there: https://developer.vive.com/resources…base/wave-sdk/, and download https://hub.vive.com/profile/sdk/Wav…ugin-beta2.zip

Decompress it.You will need to copy two folders. WaveVR and WVR:

Now copy \Plugins\WaveVR to (this is my full UE installation folder) D:\Unreal Engine\Epic Games\UE_4.18\Engine\Source\ThirdParty

So you will get something like this: D:\Unreal Engine\Epic Games\UE_4.18\Engine\Source\ThirdParty\WaveVR

Now copy ThirdParty\WVR to D:\Unreal Engine\Epic Games\UE_4.18\Engine\Source\ThirdParty

So you will get something like this:

D:\Unreal Engine\Epic Games\UE_4.18\Engine\Source\ThirdParty\WVR

And now thats it. Just open the plugin.uproject with 4.18, press the arrow to the right to play and select your focus as it should be present.

So is working now :slight_smile:

I did the exact same steps you ve described, didnt launch not sure why

I’ve followed Naitguolf’s instructions and I’m also unable to run. I keep getting a “fatal error: ‘wchar.h’ file not found” error in the build executable stage when I launch.

Other android projects I’ve tried launch fine, so there doesn’t seem to be anything wrong with my Android development environment.

Is there a specific Unreal 4.18 version I should be running? I’m using 4.18.3

Also is there maybe a Visual Studio compatibility at play? I’m using VS 2017. Should I use 2015? Or target/min Android SDK versions I should be using?

edit…worked ok after adding visualStudio build tools

Do you use Unreal 4.20.2 version?

Do we have support ViveFocus sdk for this version?