Download

HRTF 3d sound gone + Camera's facing wrong directions at level start + breaks also linetrace? CV1

Because i could not package my project i started to clone my projects to repair parts of them and rebuild elements of it.

  • I repaired the packaging problem:

I have found out that my project won’t package when i activate the **’‘Simple HMD’’ **plugin for the Oculus Rift. Also when activating the Oculus Audio plugin the packaging will not succeed. Only with those two plugins off i can package my project.

How do i solve this? I need 3d sound, and, i have huuuge camera facing wrong directions problems…

:frowning:

But Huuuuge new problems however occured which have simply destroyed, did blow up my whole project, it is dead now.

  • All the camera’s, i mean every!, camera in the whole project is broken, they all face wrong directions after level start or switching between camera’s ingame.

See illustration i made, the Camera Meshes are directed and stay where they are told to, (just what meshes do, be where they are) however at level start your view is facing into wrong directions not how i directed them with the camerameshes… Every camera has this error. This is also ehen playing in 2d on the monitor and not only an VR problem
error_camera's.png

  • The HRTF 3d sound options in the details panel are gone? I did this whole setup for VR in the Oculus Rift but now those options have disapeared in my clone of the project??? So goodbey my 3d sound,

Look this option box has disapeared and only is visible in my root backup, which is not working anymore because i can’t packige from those files:

gone.JPG

When i try to package my game from my root backup (which crashes all the time) then i get this VR sound error in the Log post:

LogEngine: Initializing Engine…
LogHMD: Oculus plugin initialized. Version: 4.11.2-2946394+++UE4+Release-4.11, LibOVR: 1.3.2, SDK: 1.3.0, built Apr 18 2016, 02:19:44
OCULUS: Info: IAD changed to 64.0mm
LogAIModule: Creating AISystem for world NewWorld
LogInit: XAudio2 using ‘Hoofdtelefoon (Rift Audio)’ : 2 channels at 48 kHz using 16 bits per sample (channel mask 0x3)
LogAudio:Error: Oculus Audio SDK Error - Failed to initialize OVR Audio system: Unknown Error
LogInit: FAudioDevice initialized.

Found the solution for the sound, it seemed my cloned project had the audio Oculus plugin off. When switched on the editor immediately took the setup how it was in the root project. So the Hrtf settings where visible again.

I have found out that my project won’t package when i activate the **’‘Simple HMD’’ **plugin for the Oculus Rift. Also when activating the Oculus Audio plugin the packaging will not succeed.

How do i solve this? I need 3d sound, and, i have huuuge camera facing wrong directions problems…

:frowning: