How to use Chinese Fonts with Text Renders

Hello,

I am trying to localize some VR games I am developing for China and Japan, and I want to use a Chinese font as an offline font with Text Render objects. Unfortunately, it seems that “multiple pages” are still not supported for distance field fonts (see image below)

I am currently using 4.18.3. Have there been any upgrades since 2016 that enable us to achieve this, or do we have to convert all Text Renders to UMG widgets? Although UMG widgets can be embedded into an actor/character object hierarchy they are not optimal for VR, and they cannot simply be placed in a level or ‘attached’ to a level-based camera for simple user messaging. Also, UMG widgets have size/cutoff issues that Text Render objects handle much easier and more quickly.

Thank you!
-s

Hi khazum,

seems it is doable. I have attached pictures for your reference.

Please to see if this is what you need.

Also, I just use a common pages for Chinese, you might need to change the “Unicode Range” for Japanese version.

Also (again…), if you have the set of characters you want to use, you can define the file path and file wildcard to limit the offline cache size. there is no need to cache everything in your case I assume.

Hope this could be helpful to your project.

3 Likes

Useful info, thanks!
I’ve just tried to import Google NotoSansCJKsc-Bold into our project, and all the characters (English AND Chinese) are rotated 90 degrees anticlockwise. They’re not rotated in any other software I’ve tried this font in, so I presume this is unique to Unreal?

I have tried NotaSansCJKsc-Bold which is also OK.

For 90 degrees rotation error with some certain Font, it normally because you got a wrong font as far as my understanding.

I assume you must choose **@**Noto Sans CJK SC but you should use “Noto Sans CJK SC” without “@”

“@” version font normally is for text vetical output usage

244944-verticlefont.jpg

244945-correctfont.jpg

And there is an old Font import page from UE3 for further information. Looks like it still worth to have a read if you are working on font related function / code.

Ah, thank you - could have taken some time to figure that out by myself.

thank you so very much for answering my post, i really appreciate it very much!

Unfortunately this doesn’t work, or it doesn’t work for most fonts maybe. I’ve tried 3. When I change the unicode range, nothing happens. Font doesn’t update at all once you’ve selected the font in the first place.

Turns out the issue is you have to click on the menu: Asset → Reimport “MyFont”, otherwise nothing updates ever.
Unreal is really only built for the western market, no documentation on this anywhere.