how to tweak an huge water material ( lake) ?


i made the swimmable water tutorial from tesla,
but i stick at adjusting the lake material:

  • i made an huge box brush for my water
  • i converted the box brush into an static mesh
  • i set the lightmap-resolution from the staic mesh on 4.0…

everything is fine up to here…

  • when i apply the water-/lake - material on it, i would like to adjust the waves…
    so i go into the material editor and tweak at the “Micro Normal”- section the “Tex Coord”-values
    in different settings, with saving these values.

but nothing happens…

it´s a real huge water area, so i have to tweak it.

what can i do?

thanks for an answer!


Some more information on what you want to do to the waves might help =]

EDIT: Ahh wait pretty sure I get you.

An easy way to tweak this is to plug all of the TexCoord nodes into their own multiply, have those multiplies going into where the TexCoords were before, then create a Scalar Parameter (just set the default to 1) and connect that one scalar parameter to the open pin on all of the multiply nodes.

Save the material, right click on the material (in the content browser) and create material instance.

Apply the material instance to your water plane/mesh and open the instance, in the details panel under scalar parameters you will see the parameter you created and now you can play with the value without saving/compiling the material every time.

If this wasn’t want you meant just say so =]

It’s because you can hardly see the waves -> go a litte bit away from the water. Then you should be abel to see the change :slight_smile:

Another alternative is to convert the TexCoord’s for the waves into world coordinates rather than scaling them up with a parameter like @Xerithas mentioned. Either way should work, but it might be simpler to use Xerithas’s solution since it is already set up that way. :slight_smile:

i will try every alternative…

thanks a lot for these tips
a nice weekend for everyone :slight_smile: