Download

How to turn shadows to low in the built project?

We’ve had a problem with lag in our game until we went to Engine Scalability Settings and turned Shadows to Low. Everything else can be Epic and it runs smoothly as long as shadows as low. Problem is, when I package the project the shadows are still there and make the game very laggy, like 5 frames per second. How do I make that “low shadows” or “no shadows” setting get carried over to the build?

Hi JStancil1,

You can set use a console command execute node in your blueprints that can enable this to retain the shadow quality LOW setting.

The console command is r.ShadowQuality [x]

Engine Scalability Shadow Quality LOW would be r.ShadowQuality 0
Engine Scalability Shadow Quality EPIC would be r.ShadowQuality

You can read more here: Scalability Reference | Unreal Engine Documentation

To use this in your game you by default you could set this up in the Level BP to be called when the level starts or you can edit the BaseScalability.ini for your entire game without setting this in each level.

20600ce1fbcb454190309ef29450bd67be1e50fc.png