Download

How to take very high res Ray-Traced screenshots?

Hello - I’m running a PC with dual RTX 2080 tis. I’m impressed with overall look, but I’m wanting to know if there’s a way to capture very high resolution screenshots - like 6K?

Mine tend to cap out around 3k or 3.5k before I get a GPU Crash. I’ve tried modifying some of the RegEdit settings, but still seems capped.

Are there ways to capture very high resolution Ray Traced images or screenshots?

Use NVidea Ansel, you can set a very high range of resolution!
Check this documentation: NVIDIA Ansel Plugin Overview | Unreal Engine Documentation

BTW, dual rtx 2080, hype

Also, btw dual cards aren’t currently supported in UE4, though they’re looking to add some support in the future.

Ansel doesn’t seem to be working? It’s a pretty janky system - sometimes works, sometimes doesn’t. Have you tested Ansel with Ray-tracing and taking very large screenshots?

Yeah - I assumed that was the case. Hoping they support NVLink so we can make use of dual rtx, particularly with all their Ray Tracing push.

Are you using the “High Resolution Screenshot” option? Not sure if this helps your situation, but I tend to get odd results using that. For taking high res screenshots, I tend to set up a Sequence and render out one frame from that at whatever resolution I need

Are you trying to use it with CinematicCameras or standard cameras? I haven’t had any issue with using ray tracing yet… I’ve even took 16k shots. Could you explain better what is not working?

You’re able to take 16k Ray Traced Images with Ansel? IE: Using Alt+F2 to open the window?

I can’t get Ansel to even open in 4.23. What version of UE4 / GeForce Experience / Drivers are you using? Ansel is constantly breaking if an update isn’t working well (like Gsync).

Yes, using the Alt + F2. I’ve just remembered that it does have some issues with the newer drivers! The one that works for me is the 430.86. And also, I’m still using 4.22, haven’t tried with 4.23 yet!

Thanks for the quick info - what about your GeForce Experience version? (when open, go to the settings, then in the general tab it will say in ‘About’). I’d love to figure this thing out - if I can get Ansel to work for high res Ray Tracing images out of UE4 that would be awesome.

Oh sry i’ve forgot! Using the 3.20.0.118 version here! Hope it works for you!

Thanks again - Looks like I’m at a dead-end since the 430.86 Nvidia drivers are not compatible with my version of windows, v1903 (the latest - which windows forced on me, also breaking my Unreal swarm). Funny enough I had those drivers previously downloaded, may have been down this path already. Ansel is likely out for me. Some combination of UE4, Nvidia, and Windows aren’t gelling.

That’s sad man :frowning: The default high res screenshoot with bumped screen percentage doesn’t work for you? Personally I don’t like it since I always get some artifacts when using it…

High Res Screenshots are capped by the GPU, so can’t push real-time ray-tracing beyond like 3.5k (vs 8-10+k in normal baked scenes).

I went on a whole journey the other day trying to get Ansel to work. Uninstalled my GPU drivers, ended up getting stuck using DCH version drivers (since Windows 10 automatically installed some and locked my Nvidia updates). DCH drivers don’t have Ansel at all. Spent a few hours just to end up back where I started, lol.
.
Ansel is still a no go in general - not sure what to do aside from wait on Windows / Nvidia / Unreal to cooperate again. Meanwhile - Windows 10 v 1903 also killed my swarm farm with new firewall stuff. I’m currently blaming the disastrous and forced Windows 10 v1903 on everything. It’s been at the root of so many issues for a lot of people.

For now, I switched back to non RTX rendering.