How to stop Textures from looking bad from afar?

I have this problem where textures look bad if viewed from a far distance:
image

While the textures are high quality if looked at from a close point:

At first, I thought it was motion blur but disabling it changed nothing.

This is the grid material that comes with the engine

Same thing.

It’s anti aliasing, there’s not much you can do about it.

One solution, is the fade the grid lines with camera distance in the material.

camera fade

I did this in the grid material, I don’t know what material you’re using.

2 Likes

Here is a tutorial I made about it. You can affect it somewhat if it is a texture: [Unreal Engine] - Blurry Textures / Materials & Mipmaps [Fix] - YouTube.

The method @ClockworkOcean mentioned is a solid one.

2 Likes

This is exclusively due to MipMapping and texture filtering. The farther from the camera, the blurrier the texture becomes. This is important to prevent aliasing, moiré and shimmering.
You actually have explicit control over this. Here is an example of a grid texture using default computed mips, vs a texture using explicitly derived mips. I’m using DDX & DDY multiplied by some value that satisfies a compromise between blurriness vs shimmering. This is a setting within the texture sample called MipValueMode.


In most cases the default engine calculated mips look great, but sometimes it’s appropriate or even necessary to derive them in some other way.

4 Likes