Download

How to stop sunlight illuminating a closed Structure?

I don’t understand one thing, when i am making a door , the outside light or simply the sunlight starts spreading in the entire room illuminating it completely bright, there is no point of putting wall lights or any other lights, i don’t want the sunlight to spread in the whole big enclosed office room???I just want it to remain outside the door with few light rays pouring inside rather than it illuminating the whole office.

1.I used new level in FPS Blueprint.
2.I use Subtractive Geometric cube to make the door in a closed office.
3.I am using Unity 4.13.
4.There is no cube reflector in the scene.
5.Just a closed office made up of walls and a single door.

“Note if in the view or the game mode i look away from the door everything turns back to normal”

“It only happens when i look at the door, the light starts to spread like a glare or bloom and suddenly everything brightens up”

“i have tried everything with the sky sphere options and the directional light options but nothing seems to stop this, this is some sort of advanced lighting that im not able to switch off.”
Eagerly waiting for a reply. Thankyou.[FONT=Arial Black]

Hey adilnadeem,

So the brighting and dimming of your scene is caused by a setting within Post Processing called Auto-Exposure.

This is on by default and there a few ways to remove the visual impact of this effect.

You can use the Logarithmic visualizer within the viewport to see how your scene will look at different Auto-Exposure settings.

712c320b213987acd54cedf6662582cbdceb5c4a.jpeg

You can also add/open the Post Process Volume actor in your scene and modify the Auto-Exposure and set the Min and Max brightness values to 1.0

81944382760698f8a68f70345a305bc706915033.jpeg

Once you set these values equal to one another there will be no adaptation of brightness in your scene.

Let me know if you are still having a hard time and I will assist you further.

Best of luck!

Thank-you Sir it worked perfectly for both of the methods.
:slight_smile: