How to stop Light Functions from projecting through meshes?

I’ve created a custom Light Function for water caustics in my game, but the light function is projecting through the walls and floors of my map. The geometry is solid (not built with planes) and I’m not using any static lighting (it’s disabled in my project settings). Is there any way to block light function projections?

Thanks!

turn off shadow casting

Really!? Why would shadow casting go through walls and floors though? I’ll try it and let you know.