how to show the shadow of objects faraway

I am working on a project with large scence size now. when the model is finished,I find the objects faraway from the camera display on the screen without any shadow. So this is what I wanna get to know.


On way I know is to take a look at the cascaded shadows, you can set the distance for the shadow there, see picture:

1 Like

Thank you for your answer,.

no problem, hope it helps you!

Accroding to your instruction,I have changed the parameter,but It still doesn’t
work well.I get too many coconut palm trees on the land.You can see ,the trees faraway from the camera look like floating above the ground.Maybe my scence is too large.By the way,my unit setting in this scence is it causing this problem?

do you have any pictures?

alt text

Hi, increasing a lot the cascaded shadow distance didn´t solve the problem??

HI RGBpixel,

Dynamic Shadows can be cast up to a default value of 20000 units (200m). However, you can type in manual amounts, but this will affect the quality of the cascades distribution for your dynamic light. The further the distance that you use, the larger the shadows will need to be spread over further quality sections (cascades) of the shadow map that is used. This means that shadows may not be as crisp closer up since they are now spread farther out.

Some alternatives that may or may not fit your project depending on a number of factors:

Static/Stationary Lighting:


  • This option will allow you to bake in shadows for your foliage and other objects in your scene, but use dynamic shadowing at closer distances.
  • Baking shadows do not incur any runtime shadow casting performance hit.
  • Adjustments for quality and world size available in the World Settings > Lightmass section


  • Static Lighting takes a while to build for larger scenes
  • Lightmap resolutions need to be set lower for your foliage (uses default meshes LM Resolution.) Set it in the foliage tool to be around 4 or 8.
  • Depending on the size of the map and number of assets, the light build may run out of memory on your scene if you don’t adjust the LM resolution, or if your sene is too large. Recommend having somewhere between 16-32 gbs of ram.

Distance Field Shadowing


  • Dynamic Shadowing at far distances for less cost in performance than Cascaded shadows.


It may be a case where neither one of these fits your exact needs, but it’s something to consider.

Thank you Tim Hobson for your answer with so much patient.