How to set up lighting to create white windows?

I am currently try to recreate something similar to what can be seen here:

I want to create windows that you can’t actually see through but still have realistic looking lighting coming through. I’ve tried by using an emissive square and a light but it doesn’t look right and the light hitting the floor looks odd (and circular). Any suggestions?

Hi BraXzy,

Depending on the final use case for this there are a couple of ways to achieve this.

The first method will assume you do not need to see the outside looking through the window.

  • first you’ll need a plane mesh setup that will be our windows
  • Create a basic material that will be your color for the window, in this case white and blend mode set to Opaque.
  • Build lighting if you’re using static, or if you’ve got dynamic no need to build.

since our material will only affect a single side of the mesh light is no blocked on the back face.

This second method will take into account that you need it to be opaque from both sides.

  • With this method you’ll need to enable two-sided in the material
  • All the other steps from above will be the same.
  • select the mesh in the viewport then go to the details panel and disable cast shadows for Dynamic and Static.

If you want to control the translucency at all you could set the blend mode to translucent and not having the option for cast translucent shadows checked (mesh details panel) will allow light to pass through even if it’s fully opaque.

Hey Tim, thanks for the reply. Option one is great for me since I just want one side. I’m essentially making dead windows that I don’t need anything behind.

I’m currently trying to do the plane trick but I’m not quite doing it right. I’ve got the plane imported into UE4, and applied the texture to one side, but it’s not letting light through. What am I missing?

Hi BraXzy,

Here is my setup:

I’ve place a single plane in my doorway to act as a window. Only one side is going to render since I’m not using a material that is two-sided (that option is not on by default). The material is just a default material with a white material plugged into diffuse.

This is the inside result:

The outside result:

As you can see on my backside there is no face that is rendered. Make sure that you’re plane is doing this same and if it is, make sure that the front face is turned to the inside.

If that doesn’t seem to be working for you, you can always disable casting dynamic and static shadows. It will still receive any shadows cast onto it but it will not cast it’s own shadow.