Download

How to set up indirect lighting

G’day everyone,

I have a couple of questions concerning lighting, lightmass etc…

Currently I am doing a little research project, trying to get to a state where I can setup and “render” a scene with a photorealistic quality…
Using Koolas approach with indirect lighting via reflectors, a sun light, together with atmopshereric Fog and exponential height fog I have set up my scene to look “nice enough for the moment”.

BUT, as you can see in the screenshot, I get this weird “shading” in some corners and am wondering what is going on?!

One of the factors that I have discovered is obviously the LightMap Resolution… In the first screenshot the Lightmap Resolution is 1024, which is I believe insanely high… in the other it is 128, which i think is also quite high… But in both it is not optimal …

So two questions:
Where do these Shading spots in the corners come from ?
And how can I get rid of them?

Each wall is a seperate object with proper UVs (screenshot 3 is the right wall for example)
Lighting is as said Spotlight hitting on Reflector, Sunlight coming through room, Sky Light, AtmoFog and Exponetial HeightFog outside…
Lightmass Settings are standard except for 5 Indirect bounces instead of 3
Scalability quality is set to maximum…

Help?
Thanks already!

Greetings,
JayCox of on3studio

interesting question, I’ll follow this thread, same problem with my models

Disable Use Ambient Occlusion in world settings then rebuild the lights and see if it helps.

Nope, already tried that. It doesn’t seem to be an isssue with ambient Occlusion. Neither if i enable or disable in Lightmass Settings, nor when I tweak it with a PostProcessVolume

What about Indirect Lighting Smoothness? Have you tried increasing that a little bit?

That’s completely normal lighting, and how corners usually end up in real life.

128 isn’t too high of a lightmap resolution, that’s just 128x128 pixels

Real life is not really like this, been looking around the office the whole day… Light never occludes like this in a corner…

Smoothness did help a bit, but it’s still there and not looking perfect… But we’re getting there!

I now have another problem … For some reason the wall where the lights shine in is darker than the inside… My first thought was that “well obviously the indirect light comes in through the window and doesn’t hit the other side of the wall” but that cannot be can it? Isn’t the point of indirect lighting that the entire scene is being light more or less equally [if nothing blocks the light obviously]?

Especially strange is I find the stark contrast at the edges of the walls, any ideas about this issue?
I have tried out so many things today that I cannot see the forest anymore because there are simply to many trees…

And seconds question of this post: What is good Lighmap resolution? My games will not be big, it’s mainly ArchViz with only a few different rooms/levels, I want it to run on PC and Mobile (IOS mainly, if possible also android). Is there a limit for file size and lighting technics for either plattform?

Thanks again, already!

I’ve also experimented mindlessly over and over again trying to solve various issues I have with my own archviz project. Just have to keep trying and trying!

The dark wall issue could be exclusive to Koola’s method and how it uses only indirect lighting from the reflector, have you tried just using a regular spotlight to force light through the window? You might get stronger ‘bounces’ back towards the dark wall that way. Or if you haven’t already, jack up the indirect lighting bounces to 100 in the world settings (I bet you already have though). You could also try putting in a skylight actor but that might introduce more problems than it solves (which is what I’m learning…)

Use the lightmap density viewmode to make sure you have enough to get good quality. If you have a small level you don’t really need to worry about memory or disk space. ‘stat streaming’ can show lightmap memory usage.

Best quality with lightmass is usually achieved with

  • High enough lightmap resolution
  • IndirectLightingQuality 2 or higher (significantly longer builds, less splotchiness)
  • IndirectLightingSmoothness .7 (reduce smoothing to get back contact shadows)
  • Disable bCompressLightmaps in world settings. Will make your lightmap textures 4x larger but removes encoding and compression artifacts.

I could take some pictures of the corners in the office here and all of them are like that unless a light is shining directly into the corner.

No, indirect lighting is where the light bounces off of surfaces, the way it looks can change based on the energy and the color of the light and the material properties of the surfaces it hits. For corners, it’s not as easy for light to bounce into them which is why they end up getting darker.

Those screenshots are looking pretty great, so I think you’ve got things going pretty well. I’m also doing an archviz project, and I’ve boosted my indirect lighting settings a lot since I don’t care about “render” times. My Indirect Lighting quality is 4, my Indirect Lighting Bounces is 100 like Koola’s (even though it’s practically pointless and free after 4), and I’ve lowered my Static Lighting Level Scale to 0.8 to increase the number of samples it takes. Also make sure your Lightmap Importance Volume just barely surrounds the environment, or else those samples go to waste. But what you have is looking great.

Thanks for your advice! The decrease of the static light was very helpful!
My current Lightmass settings are 0.8 Scale, 100 bounces, quality 4 and - against the advice of DanielW - a Smoothnes of 1.4. The smoothnes gave me what I wanted in the corners but possibly the the contact shadows are a bit off and that might be what I don’t really like about my screenshot now…

Here’s just a little update:

As you can see in the screenshots, it is getting there… What I am not happy with yet is the hard crease/Ambient Occlusion Edge thingy in between the right wall and the ceiling but otherwise I kinda like it!

If you also use the “Spotlight hitting reflector in front of window” setup and having issues with the one wall being darker than the other: I added in a high value radius, high value length pointlight, not shadowing, no falloff with a intensity of 0.1 into the room and that evens out the lighting just ever so slightly.

Also a little PostProcess Volume which by all means is far from perfect, but adding a little yellowy/orange tint did a lot for the tiny bit of mood that is in this room at the moment :smiley:

Anyone ideas on getting a smoother transition between the walls / less tough crease up there?

Thanks again and have a good one!

Greetz,
JayCox of on3studio