How to scale niagara system particles

NiagaraActor’s scale factor does not affect particle size.

How to scale paricles size like cascade?

Parent component’s scale also does not affect to child niagara.

It’s bug or not ?

I’m using 4.25.3 installer version editor.

If you want the scale of the parent affect the size of the particles, you need to check the Local Space box in the Emitter Properties.

Thank you for your answer.
But It doesn’t work. I think it affect paritcles position and rotation but scale is not.

1 Like

1 Like

Turns out I was testing it with a mesh renderer. And you’re right, the sprite rendered doesn’t get scaled, whereas the mesh renderer does.

You’ll have to work with the Niagara parameters then to change the particles size.

Thanks a lot. :slight_smile:

1 Like

I hope I’m not too late! One way I found to scale the particle (sprite) size was to go to Particle spawn and set the Sprite Size Mode to “Uniform”, then I could scale my particles however I wanted.



god bless you…

This worked for me. I was able to store references to the NiagaraComponent and then set the relative scale onto them, and then it had an effect (before, the scale had no effect)

how? thank you, when i do scale all the parameter of the forces changes and become a mess!

This it the answer I needed. Blessing to you!