Download

How to round out the end of a beam particle?

I’ve tried a few different things on the texture and material side of things, but I can’t figure out a good, easy way to round out the edges of a beam, particularly the “point” of a bullet tracer

Basically, i just spawn another particle emmiter at the end of the beam and sharp end is hidden by the it. i use beam particle with sparks at the end so it may not be suitable for you.

I went with modifying the taper property of the beam module to make it smaller right at the end.

how did you managed to do that? i played with those values for an hour and had no luck so i went with particle sparks :slight_smile: no matter what settings i typed there, beam was always striaght. if i cranked up values, it became really wide but not tapered.

I just made three taper values

time 0 = 0
time .5 = .5
time 1 = 0

that simple and it looks good and the client is happy! :slight_smile:

Still not getting it, sorry. Could you please post screenshot? where do you input those values? sorry for noob questions but i’m lost in this. thanks!

Absolutely, here are two screenshots that should help. Please let me know if you have any more questions.

52921bcc0f1fc45a9b435e2495aafd3b64a0425b.jpeg
beamexplaination2.PNG

I just finished building an temple with your name on it. It was made of cookies and i already stuffed them all in my mouth, but it’s the thought that counts (i hope). In other words, thank you!

It’s my pleasure :slight_smile:

I know this is an old thread, but is the taper factor setting broken in the latest version? I’ve been trying to taper my beam for hours and as soon as I select Taper Method to Full, the beam disappears. Any ideas?

Hey GetGooder - funnily enough I was having this exact same issue today and I have been trying to work it out for hours…

What the screen shots do not show in this old thread is the amount of interpolation points your beam has. When you set the curve for your taper on your beam, if your interpolation points are set to 0 that means you will only have the source and target. Therefore if you are trying to set up a 3 point curve and go say from values 0 -> 1 -> 0, it will ignore the 1 in the middle as it has no interpolation points to assign the increase to that value. You then end up with a taper value of 0 -> 0 i.e. no beam at all.

Try setting your interpolation points in your beam data module to something like 20. This should now mean you can assign a range of values in a curve in your taper settings.

Hope that helps! :slight_smile:

Interp.png

I did rounded beam end in material. base is rectangle and then from corners subtract something rounded. works fine however stretching is sometimes problem.