Download

How to resize mesh without having to reimport the base mesh

In UDK you could change the facing and scale parameters of an imported skeletal mesh in the editor but I don’t see a similar option in UE4 (4.26). I have a mesh that I have retargeted from Mixamo and everything works well, but in the character BP the mesh is only about half height. I was hoping to adjust the scale in the BP but the BP is the child of another and the mesh has sub meshes so if I scale the character mesh then the sub meshes scale with it. I’ve tried to do it and then put the inverse scale in the sub meshes but that doesn’t work well and I end up losing functionality. I don’t know how to get past this and for me it’s a show stopper. Any help would be appreciated. Thanks

There is a scale parameter on import. It’s just well hidden.

My 2c on it would be to open the rig in a DCC and scale it there so you can adjust other things if they need adjusting.

1 Like

@MostHost_LA Thanks for the feedback. On import, the mesh is the correct size, but when I assign the skeleton that goes with the Anim BP the mesh gets scaled down and I’m not sure how that’s even possible

It’s not.
Delete that skeleton and let the import process generate the correct one for you.

1 Like

@MostHost_LA That’s what I don’t get. When I bring the mesh into the character bp it looks fine, but as soon as I assign the anim bp the mesh shrinks. Do you think that the problem is still with the base mesh, or could something else be off?

If the animation BP is set to use the shrunk skeleton, it could possibly be causing this.

If not, the mesh itself could have a scaling parameter set in the blueprint. Which you should also check and clear.

You can always drop in an additional skeletal mesh without an assigned animation blueprint to se how it goes.

Last but not least, the skeleton has a thing called “retarget settings”.
Usually those are set to skeleton.
I prefer to use animation scaled (because I make my own animations for each character).
You could try changing those settings around to see if the issue is the skeleton in use by the BP/animation or what.
If you set an arm chain to animation scaled and it takes on a different size than the rest, then something is most definitely wrong somewhere.

Always, when in doubt.
Start from scratch.

Make a new character BP. Toss in the mesh, add in a new animation BP with just the idle, and play test to confirm it works.

If it does no, then you know that the animations themselves are somehow scaled.
So use retargeting to convert them all…

1 Like

@MostHost_LA It was the animations that were the problem. Thank you so much for helping me solve this.

1 Like