How to reimport mesh without breaking all blueprints and references?

So I imported a dragon and it had that stupid problem of Y is up instead of X or whatever. So now I’m trying to figure out how to reimport it with the option selected for forcing X. If I import it I can select that, but I can’t for the life of me find a way to replace the original. When I tried to replace the original it didn’t work right, broke tons of stuff, and somehow the primary blueprint I’m using it in still has Y as up somehow.

I’m testing things on a backed up copy I made of my project, so I can try whatever I want as many times as I want with backup copies.

Am I screwed and have to redo 40 hours of previous work with a new mesh? Even if I lose 40 hours of work I’m not even sure forcing x actually works, this stupid thing may still just do all animations sideways.

If anyone wants to give any suggestions, it would help a ton. I’ve lost an entire day of work trying to fix this garbage and it just feels impossible.

Also I can’t rotate 90 degrees inside the blueprint because I need to use the rotate to facing or whatever node and if it’s tilted 90 degrees then that node makes him rotate opposite to the system so he ends up looking away at two directions and towards the target in the other two directions, and then in-between directions are twisted between those two directions.

Can’t you just change the Import Transform and click “Reimport” on the top right? I don’t see how that would break anything.

are you talking about this? I just tried it at your suggestion and it didn’t change anything, he still moves sideways in all his animations. And yes I reimported the mesh after changing that.

Edit: I just found the rotation part of that thing and tried it, which is what I think you meant, and it did rotate the mesh, but he still is sideways in all his animations, I’m not sure if he rotated in the blueprint version, I’ll have to test and see.

Second edit: yeah unless there’s something obvious I’m missing, doing this has zero effect on how he’s rotated inside of his blueprint.

Sorry, I wasn’t thinking about the animations. You should be able to rotate the entire armature (I assume you are using Blender) so that it faces along the X-axis and then apply the transform. If you reimport it (don’t forget to zero-out the Import Transform property) then your animations should be fixed.

Okay so actually your first suggestion worked, I had to go to the blueprint and select a totally different mesh, then swap it back and it updated it there. Now though he’s just doing his equivalent of a t-pose and not calling the animation blueprint anymore. Is there something obvious I’m missing here or do I have do it the second way you described here?

EDIT: okay wait doing what I did pulled the animation blueprint off of the blueprint. When I put it back on it forces him in the wrong axis again. So I guess it’s a problem with the animations themselves being rotated. So I tested and I can reimport the animations twisted -90 on the Z and it fixes them. I guess I have to go through all 30 animations and export them onto my hard drive then reimport them from my hard drive with the rotation set to -90.

I feel like this is the wrong way to do this and going to cause problems down the line, if anyone out there has any thoughts on whether or not this is safe and reasonable to do long term, please chime in. In the future when I get other assets on the Unreal Marketplace this is 100% going to happen again and it would be really good to know if this is a smart or bad fix to the problem.

Sorry I don’t really know. Perhaps try recompiling the animation and character blueprint first and then try my second suggestion if that doesn’t work.

Thanks for the help, I edited my previous message with what’s happening. I have a solution now and the only remaining question is whether or not it’s a good solution or a smart solution long term.

To my knowledge, rotating the armature and/or the root bone should have the same effect as rotating the animations, so I would try that before spending too much time editing 30 assets.

That’s so weird because it just doesn’t. Once I throw the animation blueprint back on him, he instantly rotates 90 degrees in the viewport inside of the blueprint. Maybe if I try refreshing my blendspaces it will update it. I’ll try some stuff.

Okay so I tested this and I cannot find any way to fix this without fixing the animations. No matter what way I spin the dragon, it just resets him to a 90 degree spin when the animation starts. I’m very confused how spinning the mesh doesn’t work. If I spin him with transform in the blueprint then the animations rotate, but if I reimport the mesh with a -90 spin it doesn’t transfer like that to the blueprint. I’m so baffled by this.

Alright I give up, I’ll keep checking this thread to see if anyone knows but as far as I can tell, updating a mesh rotation and reimporting has zero affect on the animations. The animations were imported with a 90 degree spin thanks to the y axis being the z or whatever. Updating the mesh refuses to spin it once the animations are applied, but somehow rotating it inside of the blueprint also rotates the animations. It makes absolutely no sense and after 8 hours of lost time to something that would have taken 3 minutes without this problem, I’m going to admit defeat and manually reimport all 30+ animations with a -90 spin on them and pray it doesn’t cause issues down the road somehow.

There is an option in the animations to ignore the skeletal meshes rotation etc (set by default) - you can change that in each of the animations to “Local” or “Mesh” but that may introduce problems of it’s own.
I’d go with the rotate the skeleton base in each anim (click on base bone, add key, rotate bone 90* and save).
I started writing a plugin to do it - do you think it would be a handy plugin worth about $20? (select as many anims you want, right click → select +90* menu item → done)

I think it would be a handy plugin people might buy here and there, but also for whatever reason, in my case rotating it that way also yielded no result. I don’t know what hell’s wrong with this crap over here, but reimporting it the one way did the trick for me, let’s pray it doesn’t cause issues long term for me.