How to reduce the size of Windows Package for a project?

I’m using unreal engine 4.7.1.

I started a new project with the ‘First Person’ template with ‘no starter’ content.

I have neither edited the template nor added anything extra to the project.
When I package this project for windows, the output package is 319 MB.

Can I reduce this size ?

Waiting for UE4 Developers 's reply!So many users are expecting for this problem to be solved

Howdy asu619 and zhoy,

Thank you for reporting the packaging size issue that you have been seeing. I have just loaded up the 4.7.2 version of UE4 and saw that the packaging size was only 366 KB? I packaged the First Person template project with no starter content.

Would you be able to test this issue on the 4.7.2 version of UE4? Also, would you be using a source or binary version of UE4? Any additional information would be greatly appreciated.

Thanks and have a great day!

Gribbin :diamonds::diamonds: STAFF. Thanks for your reply.

What I packaged Project is the First Person template Too.Add With No StarterContent.

and more .I use the binary version released by Epic official.

I dont know why. I wanna use UE4.But this problem keep me from stepping forward

My UE Version is 4.7.2

1、Create Project using First Person Template.and with no startercontent Box Option Checked!
2、Then I check The contents In ContentBrowser.I am sure There’s none startercontents
3、Package The Project with ship Mode 。windows32
4、‘then after Packaging finished! I check the “WindowsNoEditor” total size .It is 345M.Then I Check the pak File Size .It is 247M

Howdy zhoy and asu619,

Thank you for all of the information that has been provided. I have been able to reproduce the issue internally with the steps that have been provided. I have entered report UE-11529 and placed that issue into our Bug database so that the issue may be addressed in a future release.

Thanks and have a great day!

Thanks Gribbin . Thanks Epic。

I am an unity for now and be willing to switching to UE4, also having plan to develop plugins for UE4。

Yesterday when i introduce UE4 to my friend. He was amazed by UE4’s effect and its work flow. but when i told him this probelm. he said he lost passion for UE4 immediately.

This is an urgent and basic bug for UE to fix。
Hoping UE4 will be more strong and becoming far beyond others!

I am not sure if this exactly matches your issue, but in the packages QA sent me, I see the difference is in the map:

LogPakFile:Display: “AHub_WindowShipSize/Content/Maps/Example_Map.umap” 14,075,520 bytes.

LogPakFile:Display: “WindowsShippingSize/Content/FirstPersonBP/Maps/FirstPersonExampleMap.umap” 204,870,115 bytes.

Those are two different map names, so I am not sure if they are supposed to be the same map, but it’s 200MB bigger in 4.7 - I’m not sure why, maybe our example FPS map just got a lot more complex? Possibly it more static lighting baked in. I can dig more into it if you expect the 2 maps to be the same size roughly.

BTW, I used the UnrealPak tool to check out the packaged files:

Engine/Binaries/Win64/UnrealPak /Content/Paks/ -List > PakList1.txt


I Use this command.
E:\Program Files\Epic Games\4.7\Engine\Binaries\Win64>UnrealPak C:\Users\zhouyl
Desktop\WindowsNoEditor\ExportTest\Content\Paks\ -List > e:/PakList1.txt.
But in the PakList1.txt ,Its content is “LogWindows:Error: Windows GetLastError: ??? (0)”.

when i set package setting " Use Pak File" be unchecked .Then i can see the packed files in exported files
It is only the map file taking big space.!But i cannot see what is in this file …why it is so big .?[alt text][1]

It is a so simple level .There’s no so many static lighting baked in…you dont know why? i’m confused too

If i Create an empty Project with no starttercontent The packaged Content Pak File is 34.3M .Its also big.

Empty Project .Why the pak file take 34.3M

A few things:

  • Sorry about my UnrealPak command line, the wiki stripped out my brackets, so is missing the filename. It should read:

    Engine/Binaries/Win64/UnrealPak :ProjectDirectory:/Content/Paks/:PakFilename: -List > PakList1.txt

(Replacing the bits between colons with your particular stuff)

  • There is some basic engine packages that are always added to the pak files. Once you use the UnrealPak command on your .pak file, you can see what is large in there. It may be some localization data files, and slate content (are you using Slate in your game?)

  • You can see what is in packages with:

    UE4Editor -run=PkgInfo PathToPackage

HOWEVER, that does not seem to work with maps right now. I am tracking that down now to see if there’s a way.

  • You can compress your .pak file with a manual command line. In 4.8 we are planning to have a checkbox for that in the editor for packaging settings. If you want to try it now, I can help you with the manual packaging command line.


Okay, this command line will work with maps:

UE4Editor StrategyGame -run=PkgInfoCommandlet …/…/…/Samples/Games/StrategyGame/Content/Maps/TowerDefenseMap.umap -exports > Exports.txt

(Fix up for your map, naturally). You can Add -simple before the > Exports.txt bit to see a simple format (which you can use with Excel to sort by the size column).


OK !Thanks Josh Adams for providing so many helpful tips.I’ll take a try !

Hey zhoy,

Just wanted to check in with you and see if you were able to try out the fix from Josh? Please be sure to let us know if you have or when you do so we can respond accordingly.


Sorry I can’t get it resolved .Waiting for Version 4.8

Hi zhoy,

Just wanted to touch base with you. We have assigned out the bug to another Dev and it is being worked on currently. I am unsure as to when this bug will be implemented but I will be sure to keep you updated.


I cant find any optimization in version 4.8… is it any?

Hello DogRush,

Could you please explain further regarding what you’re wanting out of optimizations? Are you stating that the file sizes from 4.7.6 and 4.8.3 are vastly different in size?

Looking forward to hearing back from you, thanks!

hey! sorry for my comment, i started to test things a lot, and finally found this parameter witch helped me to reduce the file significally so I guess it’s solved and working great