Download

How to Recieve and cast shadows with Translucent Material

Hello,

I am strugling to create a curtain material. Basically I need something like this:

4b7034b2e93483e5ee94bd966be51fa62231a562.jpeg

I am using ray traced shadows, and I am aware that translucent objects do not cast shadows in ray trace…but as this image show, there should be shadows working with lightmaps…so my plan was to calculate the lightmaps and turn off in the material the “cast raytraced shadows” so the dim light would appear from the lightmaps.

I have two problems, as you can see in the next image, I can not get the material to dim the light, even with ray traced shadows off in the directional light…the material is set as:

Blend Mode: Translucent
Shading mode: Default Lit (also tryed subsurface, no luck)
two sided: true
cast ray traced shadoes: false
Translucency Lightning mode: Surface forwardshading (I use this because I want my object to recieve shadows, also tryed the Surface Translucency Volume with no luck, see post refence down here)

In the object details:
Cast Shadows: True
Volumetric translucent Shadow: true

In the directional light: Cast Translucent Shadows: True

as you can see, no dim light

1de5fd30581d70370e61c19545e26e38b6b1700e.jpeg

The second problem, is that I use the “Surface forwardshading” translucency mode in the material, in order to get shadows from other objects castet in my object with this translucent material applied. As you can see in the next image, the quality of this shadows is not good:

d909c566dcae3de65d656adb9896567b39b6c476.jpeg

As I already sayd also tryed this from another post, but not working for me, even using a geometry with thickness:

https://answers.unrealengine.com/que…ml?sort=oldest

Assuming that you have multiple materials setup for your mesh and the window material is it’s own material you will need to set the following things.

Material: Blend Mode: Translucent Two-Sided: True Lighting Mode: Surface Translucency Volume

Then for your mesh placed in the level select it. In it’s Details Panel make sure that Volumetric Translucent Shadow is set to True.

This will cast a shadow from a translucent material, however the more opaque the material the more you’ll notice artifacts on the mesh itself.

Here is an example with a simple cube mesh and basic translucent material.

You may also notice that there is transmission of light (ie. color of the translucent object does not cast to the ground). This is not implemented currently and can only be done by using only static lighting

https://answers.unrealengine.com/storage/temp/68159-translucent

So my questions are:

1 - How can I do a simple translucency material that dims the light that goes trough the object?

2 - How can I make that my translucence object recieve shadows?

Thank you very much!

I see the problems in the photos, but it doesn’t appear that the problems are caused by translucency itself. You said the directional light is set to cast translucent shadows, yet is Affect Translucent Lighting also enabled for that and the skylight?

How I understand two-sided is the object / mesh is lit from outside on its surface and from within it on its inner surface (it generates normals on the inside that point to its center). I could be a bit off about that, but in the case of a cloth material and its mesh, I would think two-sided could easily dampen or prevent shadowing, and thus dimming the light passing through it. What should also be enabled is Transmission in the lights, and in the cloth material. I know it says it affects subsurface shading, but wouldn’t it function similarly with non-subsurface materials such as cloth? As far as the incorrect shadows on the top of the mesh (where the structural beams cast a shadow over it), have you tried modifying Shadow Bias, Shadow Slope Bias, and/or Shadow Filter Sharpen? Sometimes those default values are not correct for uneven, curved, and sloped surfaces…in fact, they’re not right on the flat surfaces either sometimes, as I’ve experienced. They’re intended to correct shadow accuracy, so how about giving those a shot?

yes, they are

I have no idea of technical aspects, I have transmission active in the directional light, but I can not finsd it on the material…maybe it has another name?

Tryed, but not the solution. But now the shadows are good again, not sure what fixed it…

I also discovered that getting shadows out of translucent materials is only possible with static directional light, as I was trying it with a stationary, that was the main thing.
**That said, Is there any way to recreate that effect with other type of material or configuration that would work with a stationary directional light? **

marked in red the dimmed light from the translucent material with static directrional light

Thank you!!

I don’t understand why you were getting no dimming of the light with a translucent material. I applied a translucent glass to a mesh in my test project (what I use to test things and learn), and the shadow is dim, not completely dark or not showing. I really think it is Transmission that needs to be enabled. But there must be one or a few other aspects that weren’t used by the cloth material before with a stationary light. Stationary is baked indirect, and dynamic direct, so perhaps it is settings that need to correspond to those two facets of a stationary light to get proper translucent shadows.

the material is the same, with static lighting I get the light dimmed, with stationary no shadow at all.
the transmission is active in the directional light, but as I said, I do not find the transmission option on the material. can you show me where it is please?

so as I understant, you get the light dimmed with stationary light and a simple translucent material?

I get the light dimmed with movable directional and skylight lights. No point / spot / rect lights in the scene. Not ray-traced either, though I initially started it using ray tracing, and wasn’t sure if it was working right so I changed to non-RT dynamic. That’s where I’m seeing the disconnect between movable and stationary is in transmission, translucency, and even reflections regarding shadows in particular. Stationary needs certain settings, and movable needs certain settings to function correctly and have flexibility, is how I’m learning it.

I’ll reply in a bit about transmission in the material.