Download

How to prevent SkyAtmosphere appearing in scene captures?

The title says it all, I have a scene capture that is using a ‘ShowOnly list’ with 3 meshes. When SkyAtmosphere is added to the scene it is captured too and I can’t find a way to prevent this. I have turned off everything in the scene capture except static mesh and it is still appearing.

Weird.
I couldn’t get it to render in a scene capture if I tried.

What engine version?

Another thing to disable is fog effects. Maybe that’s what you forgot to uncheck?

4.27

Fog is disabled too.

me too, I try add to the hidden actor arry,but it is still appearing.if you wan’t use static texture,you can creat a new map, and use “SceneCaptureComponent2D” to creat a new “CanvasRenderTarget2D” and creat static texture ,hope it can help you . XDD

Could you move the sky atmosphere to a second map so that it’s excluded on that basis?

You could greenscreen it by rendering a mask from the same location. Set the sky to all white and disable all lighting so everything else is black.

Definitely not capturing for me.

Could be the capture source. Could be the disabled options for skylight and Atmosphere

Quick debug here

Fog on, you see something that looks like the atmosphere. Fog off, texture is empty.