How to play the Collab Viewer template on Quest 2?

Unreal Engine comes with a lot of templates, Collab Viewer being one of them. I want to use that template on my Oculus Quest 2 device but I can’t understand how to. I opened a new project with the template and packaged it for Android ASTC then installed it on my Quest using the SideQuest app but when I opened it on my headset it opened in a window (the initial menu where we are asked to enter the username and host or join session) and after I managed to click it with my controllers, the level loaded in the same window and not 360 immersive. Plus the controls didn’t work at all.

My goal is simple I want to install this template on 2 headsets and use the multiplayer functionality. I can also make the PC host and have them both join it as clients if necessary.

Please tell me how to install and play the template on Oculus Quest!

1 Like
  1. Go to BP_motion Controller
  2. Top Left click on HAND
  3. Go to Details
  4. In Details go VISUALIZATION
    That should do it.
1 Like

Hello, I have tried this solution but it only remains a window in Quest 2. If you have any other i would appreciate it.

1 Like

I also have the same problem. My oculus quest 2 only shows a screen of the collab session. Did any of you find a solution?

Can anyone help with this problem? In addition, the template opens with some problems with StaticMash objects and when configuring the model to pack for Quest 2 the unreal says “failed to load (DatasmithRuntimeActor)”

The Collab Viewer Template is not configured for Quest out-of-the-box. It’s possible, but requires a bit of modification, both configuration and content (for performance reasons).

I understand, but since there is the possibility of using it in multiplayer VR, it would be the ideal resource for my project. Could you point me to a tutorial on this configuration? I can’t find it, apart from the fact that the project already opens with errors

I can’t see the entire error message but it looks like you’re missing default engine assets - did you perhaps delete them thinking they were in your own project?

I just created a “Collab Viewer” project and this window is displayed without me having touched the project.

Even if I use the “webinar” template the result is the same.

New Project (U4.27):

I solved this problem by reinstalling Unreal. I don’t know what caused the situation, but even the default Unreal sphere was missing StaticMesh

Two possible solutions: You accidentally deleted content from the Engine, or, it didn’t get properly installed in the first place. Glad to see you were able to solve it.

Probably the first option. But my happiness was short-lived, the VR mode in Quest 2 doesn’t work. Application in Quest 2 only opens in windowed mode and does not switch to immersive mode T_T

Make sure the project setting “Start in VR” is set to True

Hi all, I got this working and the steps are here: