How to Override Max In-Game Resolution of a HDRI Cubemap?

I’m using a SkyLight with HDRI lighting and it seems the max in game resolution of a cubemap is 512x512, I can’t seem to find the setting to override that. Can anybody help me out?

is this still a problem?

this is a problem for me. setting Mip Gen Settings in Level of Detail to “noMipmaps” does not change max in-game resolution