How to Merge Materials with Opacity Masks?

When I try to merge the materials of a tree (bark, leaves), the leaves lose their opacity.

I’m using the UE4 editor tool (Window > Dev Tools > Merge Actors).

I’ve tried different combinations of Textures (Opacity Map, Opacity Mask Map) and Blend Modes (Opaque, Masked). I’ve even gone so far as to add an Opacity Mask and Blend Mode to the bark material.

The results are all equally horrible.

I understand SpeedTree has a merge materials option. Haven’t seen the results.

– bump –

Could this be caused by the settings you are using with the Merge Actors tool?
There are a lot of check boxes on that thing, I bet some of them affect the way the materials come out in the finished product.

EDIT: Oh! I see…those things you mentioned are the selections in the Merge Actors tool. I thought you were changing the materials themselves. No idea then, sorry.

Yeah, I tried a bunch of stuff. And I did change one material – added a opacity to the bark, bc the leaves had opacity.

Maybe merging doesn’t work with opacity?