How to make Parallax occlusion map stick out instead of concave?

Here I have this padded room material I really like, except it creates holes into void at intersections, because the material goes inside the wall mesh, causing the walls to no longer be connected. is there a way to adjust the height of the rendered texture?
For context, here is the same texture with no parallax mapping. You can notice, that the corner hole is not present:

Here is the material setup:

I tinkered with the settings a bit. My conclusions are:

  1. Set reference plane to 0
  2. Parallax Occlusion doesn’t like rendering perpendicular pixel depth ratio. Disconnecting it from the node made the effect a bit less impressive, but much less dimension breaking.
    Here’s the result:

    I’ll mark this thread as solved, in case someone else stumbles onto it in the future, but if there are better ways of going about it, I’ll be happy to learn about them.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.