Download

How to make one exact decal affecting only static meshes

I trying to make a decal that’s affect only static meshes. But in decal actor there’s no option for that at all. I do realize that there’s an option in meshes themselves to not to receive decals, but I need decals on them. I need only this one particular decal not affect my skeletal, and other movable meshes…

There is no way to blacklist/whitelist decals and actors yet.

Yes, it is certainly very annoying having level geometry decals which affect skeletal meshes that walk too close to them.

No, there’s not anything you can particularly do about it. I THINK it’s a limitation of DBuffer decals that they can only affect static geometry so maybe if you try setting this particular decal up as a DBuffer decal it will work… I never can seem to get DBuffer decals to work though.

I have DBuffer decals working. But they also affect skeletal. Besides, I need Emissive decal, but DBuffer decals doesn’t support Emissive channel.