Download

How to make material receive shadow but not cast??

Hello, I am pretty new to using this engine and an trying to create a very flat simplistic grass and am having problems getting the mesh to not cast shadows but at the same time receive them from other geometry in the scene…

Does anyone have and suggestions I could try out? im pretty stumped. Cheers :slight_smile:

To add some context to my inspiration I want to create grass that is flat and simple in regards to the upcoming PS4 game The Witness

Hi SaltyDanger,

With your mesh in the viewport you can select the object and uncheck cast shadow. This will allow it to still receive shadows from other objects in the world that cast shadows but not give any of it’s own.

See the attached image for reference. :slight_smile:

Thank you!

Tim

Thanks Tim, that did the job. However for my grass material that uses a Translucent blend mode I cannot seem to get it to receive shadows.
I prefer this blend mode as the grass seems to ignore lighting and blends well with the rest of the grass.

Cheers

Hi, I had the same issue and I’ve figured out a way to do The-Witness-style grass.

You need to point grass material* normal vector* to the sun (or just up). Thus it will always be uniformly lit (unless your light source goes under horizon). To do so you need to uncheck “Tangent Space Normal” box (it will allow you to direct normals independently of actual surface angles) and to connect a constant vector (0,0,1) to the “Normal” pin. (0,0,1) is blue color, which implies that your normal is pointed up along Z, and since the “Tangent Space Normal” box is false, that normal vector will be pointed along world coordinate Z.
Nice thing is that the grass will still recieve shadows.

Translucency doesn’t receive shadowing guys, at least not Static shadows anyway.

For foliage, you really want to be using the Masked blend mode anyway, it’s slightly cheaper, and the anti-aliasing will break up the pixels at the edges of the mask. That or Subsurface scattering if you want a fancier material.

Also as for the above trick, that only works for grass, not so much trees and bushes and stuff :slight_smile:

sir, u r best man ever