Download

How to make looping moving particle emmiter longer than one second?

Hi!
I must be doing something wrong. because what I want to do seems to be so simple, yet the results are all wrong.
I need a particle system that has emitter moving on x and y axes for lets say 5 seconds and then loops the same movement.
1 I make a new emitter in empty particle system.
2 In “required” module i set Emitter duration to 5.0
3 add an “initial location” module and set start distribution to “Distribution Vector Constant Curve” and check “Is Looped”
4 add three points with In Val 0.0, 2.5 and 5 (to set the position of emitter at the begining, middle and end… that is fifth second)
5 change the Out Val on only the middle point to x=150 (leave other coordinates at 0 to get a simple loop of emitter going from side to side)

Now I get movement of the emitter, however I get movement for only one second, its just a fifth of the planned animation, then the emitter stops; stays on spot for 4 more seconds, and then just snaps back to the starting location, and loops this

What is wrong?

I have noticed that if I set “In Val” to 0.0, 0.5 and 1 i get the full animation (back and forth) but it happens in just one second, and nothing happens for the rest 4 seconds. :frowning:

Is there somewhere else where I need to set something to get the animation to stretch through all 5 seconds of duration of emitter (and loop).

Thank you in advance, I already lost too much time on this one :smiley:

So? Any ideas? is this bug or a feature? Am I doing something wrong?

Is there a separate setting for loop duration when using curve distribution (apart from emitter duration)? if so where is it?
I tried this in 4.10.0 I get same results, whatever the serings for curve, and emitter duration, only first second of curve plays out.

The curve editor in Cascade is pretty low on features too, ability to set duration of emitter or loop in some kind of header would be great. Also adding new module in emitter should change focus to that modules properties imho.

Did you set the Lifetime-module of the Emitter to 5 seconds aswell? Not just the duration of the Required-module.

This seems to be a bug to me when using absolute time of the emitter.

https://answers.unrealengine.com/questions/278044/setting-initial-color-over-emitter-duration-does-n.html
https://answers.unrealengine.com/questions/304272/particle-absolute-time-unable-to-go-over-1-second.html

Thanks tabi but this is not the problem as I want my particle lifetime to be short and my settings attached to global setings long, read 3dgo’s reply, sadly it is a bug

Bingo! thanks alot! This bug shortened my life for 2 days :-/

Hope it gets fixed soon as it renders a huge part of particle features useless.