Download

How to make a hidden glowing mesh?

Hi!

I am making an emissive dynamic light material for an actor in the scene.

The actor emits light and injected the light color into LPV without a problem, however, I would like to hide the actor but left the emissive light on.

I’ve tried toggling “visible” and “actor hidden in-game” inside the actor’s rendering subcategory but whenever the actor is hidden, the emissive light also

vanish.

I would like to keep the emissive light but hide only the actor’s mesh.

Is it possible for me to do that in UE4?

Thank you.

You won’t be able to do that, the LPV is dynamic so it’s not going to be able to keep track of something that isn’t there anymore.

Hi @darthviper107 ,

I was following this blog post to get my LPV emissive light working: http://joewintergreendev.tumblr.com/post/134319577976/today-i-switched-to-fully-dynamic-lighting-for-my

In the post, he said

[quote]

…So my gnarly solution, pictured above, is for every torch in the game to have an invisible, light-emitting sphere on it. So I’m actually not using any PointLight or SpotLight components, just approximating the light with hidden glowing meshes.

[unqote]

So that is why I like to know if it is possible to create a “hidden glowing” object at the first place.

I tried scaling vertex in material (using world position offset node), scaling object and adjust scale bound, render the object in depth pass, but to no avail.

My only suspection left, is that the author is using a sphere mesh with flipped normal + one side material, I’ll try this when I get back home.

I’m curious about this too, though I’ve been having trouble even getting emmisive materials to work with LPV (despite the option in the material being selected).

Hi, @DuncanT.

After some trial, the flipped normal method doesn’t work either.

But I did find out that, it is actually possible to hide the emissive material from the camera and inject light into LPV.

You simply hide the emissive object inside your wall and let the emissive light bleed out from the wall.

Player won’t see the emissive object, but LPV will propagate that light info into the scene.

I’m not sure if the author uses this method for his LPV scene setup, but at least this method works for me.

As for your emissive light setup issue, did you have a directional light in your scene? (Set as movable?)

Did the directional light have the option “Dynamic Indirect Lighting” and “Cast Shadow” turned on?

If you go to Show > Visualize > Light Propagation Volume, toggle the option on, did you see the voxel representation of your LPV?

If all the above are correctly set, then you should have a working LPV already.

(Edit: There’s also this setting inside your UE4 installation folder, “Engine\Config\ConsoleVariables.ini r.LightPropagationVolume = 1” need to be added)

You mentioned you set an option in the material editor, is it “Emissive (Dynamic Area Light)”?

If that is the case, then you and I have the same setting, maybe there’s something wrong with your other settings?

I’m using UE4.16.1 by the way.

Yes to all of those settings. I had emissive work once only to break in about a minuteand not work again. I’ve tried it in multiple projects and versions of the engine with no luck. Quite weird.