How to launch multiple levels to Android?

Hello, I am able to successfully launch individual levels to my Nexus 7 for testing but using Open Level to proceed to the next map opens the default Example_Map rather than the correct map. The level loads correctly when I do a Play as Mobile on my PC. Is there a trick to getting Launch to correctly load all of my levels on an Android device? Do I have to fully cook a package in order to test level progression?

Thanks!

The secret lies in the “Swing Ninja” somewhere. I’ve been using that as a base to start my own project from, and when I deploy the Swing Ninja project directly to my Kindle Fire, it loads the level fine. When I create my own map, and change all of “Open Level” blueprint commands to open my new map, it starts over with the default starter map.

So, the “Open Level” command does work, it works with the downloaded example Swing Ninja. However, I could never figure out why I couldn’t open a map that I personally made. I’ve seen a number of people stumble on this one for mobile development, and haven’t seen any answers yet.

I’ve had to just change the way I’m building my project: Instead of creating multiple maps, I’m using Multiple Actor Blueprints, similar to Tappy Chicken. One main map that contains multiple Actor Blueprints. So everything that was going to be in a “level” is now in one “actor blueprint”.

And now? Open Level Blueprint doens´t work on Android with own Map

I’m also having the same issue, has anyone from earlier figured out a solution?

Nope, have not had a response from any Unreal folk either, even packaging the full package to device has not solved this issue for me. I am currently working forward around this issue hoping that it is eventually resolved.

Any progress on multiple level loading?

Hey Guys,

Use this answer from Unreal. It work´s!

2
Hi,

Could you add these lines inside your DefaultEditor.ini file, and see if it works for you?

[AlwaysCookMaps]
+Map=/Game/Maps/MyMapName

DefaultEditor.ini should be in Config folder of your project. Replace MyMapName with a name of the map you want to open with OpenLevel BP node.

I found thread with that advice earlier and therefore had those lines already in place. Just now i tried to built with different build configurations. TEST-configuration worked and additional levels are loading as expected.

Did this bug ever get fixed or do we still have to do the work around?

-Use the tab levels, from which you will starting your app.

-add all the levels in that tab

-hide them

-now launch your app to your phone and it will open any level as expected

I laughed when I read your decision.
But it didn’t make me laugh when it worked.
Thanks a lot!

Thanks a lot, it helped

On the viewport its working as it has to but on android ,fromm main menu level to another level but not more than 2 levels are working it opens the default level when i try to open my next level.