Download

How to integrate nvidia flex into unreal engine 4?

I downloaded the nvidia flex sdk and extracted it, but i don’t have a clue how to use this in unreal engine 4. How do i put this into unreal engine 4 so that i can use it in that engine?

Go to here: https://github.com/NvPhysX/UnrealEngine (Make sure you are logged into Github otherwise you will get a 404 error) and download the Flex branch, already integrated into UE4 (4.7.4 or 4.7.6 I believe)

or go to here: https://github.com/GalaxyMan2015/UnrealEngine - And download my 4.8p3 merged branch of VXGI + HBAO + HairWorks + Flex

Neither of these are working unfortunately. The first one still gives me a 404 error even though I’m logged in to github.
The second link also gives me a 404 error. On the second one, I went to your galaxyman2015 page and nothing is public anyway so I can’t see your merged branch. Pls help.

still doesnt work. Is there any other way so that i can use nvidia flex in unreal engine 4?

The links certainly do work, it means you have not linked your github account to your UE4 account. (This is evident by the fact you cannot see my repo, which is a fork of the official UE4 repo, so if you had access to the UE4 one, you would be able to see mine). If you can reach the main UE4 github page, you can access the above two links. So I would make sure you have mapped your account correctly. Step #2 in the link Mikand79 provided.

thanks thats worked, i did in fact forget to link my github account with my ue4 account, i thought i already did it but i didnt.
where is the flex branch i need to download and is there any steps i need to follow?

Windows

Install GitHub for Windows then fork and clone our repository. To use Git from the command line, see the Setting up Git and Fork a Repo articles.

If you’d prefer not to use Git, you can get the source with the ‘Download ZIP’ button on the right. The built-in Windows zip utility will mark the contents of zip files downloaded from the Internet as unsafe to execute, so right-click the zip file and select ‘Properties…’ and ‘Unblock’ before decompressing it. Third-party zip utilities don’t normally do this.

Install Visual Studio 2013. All desktop editions of Visual Studio 2013 can build UE4, including Visual Studio Community 2013, which is available for free. Be sure to include the MFC libraries as part of the install (it’s included by default), which we need for ATL support.

Open your source folder in Explorer and run Setup.bat. This will download binary content for the engine, as well as installing prerequisites and setting up Unreal file associations. On Windows 8, a warning from SmartScreen may appear. Click “More info”, then “Run anyway” to continue.

A clean download of the engine binaries is currently around 2.5gb, which may take some time to complete. Subsequent checkouts only require incremental downloads and will be much quicker.

Run GenerateProjectFiles.bat to create project files for the engine. It should take less than a minute to complete.

Load the project into Visual Studio by double-clicking on the UE4.sln file. Set your solution configuration to Development Editor and your solution platform to Win64, then right click on the UE4 target and select Build. It may take anywhere between 10 and 40 minutes to finish compiling, depending on your system specs.

After compiling finishes, you can load the editor from Visual Studio by setting your startup project to UE4 and pressing F5 to debug
**
I have done all of these above so how do i open this in unreal engine 4?**

Its a separate build of UE4. So if you have done all the above steps, then you have a build of UE4 with Flex integrated, so you need to launch it, create a new project (or open the example project) and now you can start using Flex

where do you find the new build? pls reply

Also how do you get these flex assets to work in ue4, like fluid in a cube, for example. I have no idea how to do this?

Launch from visual studio, if you have indeed compiled it correctly, this will work. As for creating flex assets, refer to the doco that comes with the branch, it shows you how to setup each type of asset and the sample content which has different levels showcasing the different types of assets.

Doco location (Official branch): FlexProject/Documentation
Doco location (My branch): Doco/Flex

hi galaxyman2015,i want to use vxgi,i downloaded the zip file of https://github.com/GalaxyMan2015/UnrealEngine/tree/Merged and unzip(right-click the zip file and select ‘Properties…’ and ‘Unblock’ before decompressing it. Third-party zip utilities don’t normally do this.)i didnt find the unblock so i just unzip it with winrar.after that i run the setup.bat and wait for download to finish(about 3.5gig)then i did Run GenerateProjectFiles.bat and run the UE4.sln with visual studio and did the process of buil and when it finish i got 4 error like this (Error 6 error LNK2019: unresolved external symbol NvAPI_D3D11_CreateRasterizerState referenced in function “protected: struct nvgiutil::FVXGIRendererInterfaceD3D11::StateSet const & __cdecl nvgiutil::FVXGIRendererInterfaceD3D11::getStateSet(struct VXGI::RenderState const &)” (?getStateSet@FVXGIRendererInterfaceD3D11@nvgiutil@@IEAAAEBUStateSet@12@AEBURenderState@VXGI@@@Z) E:\UnrealEngine-Merged\Engine\Intermediate\ProjectFiles\Module.D3D11RHI.cpp.obj UE4) and this (Error 7 error LNK1120: 1 unresolved externals E:\UnrealEngine-Merged\Engine\Binaries\Win64\UE4Editor-D3D11RHI.dll 1 1 UE4
****) what should i do now plz help me

When you run setup.bat it actually replaces files that VXGI requires. So you need to re-extract from the zip file all the files from Source/ThirdParty/NVIDIA/nvapi and overwrite. Then recompile and it will work.

hi galaxyman thank you for answering,as you said i did overwrite those file and recompile and this time there was no error and built it.then after i tried to run ue4 editor i got this error when engine wants to loud
engine crash report:MachineId:892DCDB2403208BB815A5EAF95F2582B

Unknown exception - code 00000001 (first/second chance not available)

Fatal error: [File:E:\UnrealEngine-Merged\Engine\Source\Runtime\Engine\Private\ShaderCompiler\ShaderCompiler.cpp] [Line: 86]
Invalid ShaderCompileWorkerOutputVersion. Rebuild Programs -> ShaderCompileWorker to fix this.

KERNELBASE + 40541 bytes
UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 285 bytes [e:\unrealengine-merged\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
UE4Editor_Core!FMsg::Logf__VA() + 463 bytes [e:\unrealengine-merged\engine\source\runtime\core\private\misc\outputdevice.cpp:526]
UE4Editor_Engine!DoReadTaskResults() + 160 bytes [e:\unrealengine-merged\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:94]
UE4Editor_Engine!FShaderCompileThreadRunnable::ReadAvailableResults() + 580 bytes [e:\unrealengine-merged\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:903]
UE4Editor_Engine!FShaderCompileThreadRunnable::CompilingLoop() + 390 bytes [e:\unrealengine-merged\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:1029]
UE4Editor_Engine!FShaderCompileThreadRunnable::Run() + 128 bytes [e:\unrealengine-merged\engine\source\runtime\engine\private\shadercompiler\shadercompiler.cpp:514]
UE4Editor_Core!FRunnableThreadWin::Run() + 102 bytes [e:\unrealengine-merged\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
UE4Editor_Core!FRunnableThreadWin::GuardedRun() + 93 bytes [e:\unrealengine-merged\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
kernel32 + 91437 bytes
ntdll + 181537 bytes

You have to build Shader Compiler Worker too, the one shipping with setup.exe doesn’t work in VXGI enabled builds. It says so in the error message too :wink:

i have to confess,befor your advice i re-extract the hole zipfiles and overright it onthe hole files of ue folder,maybe i destroyed it,but the compile goes alright after re-extract the fils that you said(Source/ThirdParty/NVIDIA/nvapi)
sorry i have no idea about visual studio or compiling:(

thanks recompile -program-shadercompiler and it works now:)
isnt there any guide except overview pdf for vxgi?
where can i find some information about it?

how do you launch it from within visual studio, what do i click on?

What about selecting the wished for target and ‘Start without Debugging’. Isn’t it a bit dared to get started with such a complex thing when you don’t know how to start build products? It might be easier for you to get started using the default UE4 install, lern some basic stuff and then look at more complex things after you aren’t all the time wondering what you are doing. I think its true for both UE4 and VS 2013. Don’t feel offended, I really mean it as doing good; UE is going to be an unhappy experience to you otherwise.

Here are some UE resources:

https://docs.unrealengine.com/latest/INT/ (index to all the documentation resources Epic set up)

And one link for the GameWorks branch (must read for ppl wanting to use it…)

thanks mikand i use ue4 for archviz and i worked with default ue4 for about 3 month.really need the vxgi