Download

How to increase shadow fading distance ?

Hello. How can I increase shadow fading distance ? I googled it and I found people who also had problem with it but I only found solution with console. I am talking about these commands:

Yet I don’t know how to change them, I tried to type it in couple different ways in console line but it isn’t working.

Can someone please explain to me how can I increase max distance for my shadows to be visible ? I already tried to play with my directional light setting but it isn’t working either, why such “obvious” function is hidden so deep anyway ? xd

Thanks and Cheers !

Maybe I am missing some important information. I’m using directional and skylight. Both are set to stationary light and shadows are baked (for most of my meshes).

The problem is that if my camera is far away from mesh, shadows on this mesh start to slowly disappear. And if I am running fast through my map, shadows starts materialize ahead of camera which just looks weird and it is very visible.

Can I do somehow about it ? I mean - can I somehow increase distance when my shadows are visible ?

Might answer might be wrong but here is what I think is going on. If the light is stationary, then using the cascaded shadow maps, the light will have dynamic shadows in the cascaded region (defaulting to 2000 I think) that is transitioned to statically baked shadow maps. This way, you get better resolution near the camera since lightmaps might provide too low resolution shadows plus your foliage can be animated and shadows are animated as well. This might be you scenario since there can be a huge difference between cascaded and statically shadowed environment. You can simply change the distance where the transition from cascaded to static shadows occurs in the light setting. Alternatively, you can set the light to movable and use totally dynamic shadows using distance fields (you have to enable distance field generation for this as well). In either case, both methods use cascaded shadow maps closer to the area.

If you do not use cascaded shadow maps, then all the lightning is static and you do not see shadows for any dynamic objects. Static objects, however, should have a constant lightmap. Also, LOD on meshes may change the lightmap as each LOD for object has its own map. I think you can still use Inset Shadow feature for dynamic objects you need shadow for (like character). Hope this is in any way helpful.

Far Shadows

Far shadows are in the engine now!

https://forums.unrealengine.com/showthread.php?34610-Thank-You-For-UE4-!&p=529311&viewfull=1#post529311

Rama

FarShadowsInUe4.jpg